summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-22 08:49:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-22 09:25:17 +0200
commit0f134c13c711abff6ff3fc5de44f8eca2626e64b (patch)
tree4a0382406ebc4829bfe25588b6ca6a41d0574cd0 /dev-python/marshmallow
parentdev-python/sqlalchemy: Bump to 1.4.22 (diff)
downloadgentoo-0f134c13c711abff6ff3fc5de44f8eca2626e64b.tar.gz
gentoo-0f134c13c711abff6ff3fc5de44f8eca2626e64b.tar.bz2
gentoo-0f134c13c711abff6ff3fc5de44f8eca2626e64b.zip
dev-python/marshmallow: Bump to 3.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.13.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 5c02d8761dea..6033f56a6c9c 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -2,3 +2,4 @@ DIST marshmallow-3.11.1.tar.gz 173844 BLAKE2B edd816ccd254dc52e01a2e067ff3037fa5
DIST marshmallow-3.12.0.tar.gz 174790 BLAKE2B 07539540f361137dd2fa2d5c884e279137a82f69e8a9e294d6abe4c566c98f74a1836018618682ac0a08f1e0d1510dbffa6d9c030a98e2cba48230697742b7e3 SHA512 7b91ec42dffbb979bede21fbab17cfb081068eea54d02aaef991b58e884cc5675fb17d5f56278794e5c33960bf29951ba74533abb9a025228a524a4e413bd312
DIST marshmallow-3.12.1.tar.gz 174784 BLAKE2B d3540ba833950d730db719c8ac7e8d66a54a4b06d0decc161d9b1f82d2012db2df7cc376bf3fb322e8d07e60057409f2e6ab761561e822c942d189418c70b9fa SHA512 aadbf9c3b45a5b435ce7fd7f60a4318f393221f23687be7b48af43deee111f48806489169815122f297539614a81700a435cc579cf5b7d0fffea2a2809368db9
DIST marshmallow-3.12.2.tar.gz 174529 BLAKE2B 67c8431c1b013f40c3ebbb23631be3060e978a4cb71f3802b810d943bb69fd32bea59b3b7c92df5ea3cbcef28ef7b64f32c9fb1a6a3d5d42e4eabd6ce4b7958e SHA512 d1f5e695564d0df10ec3f74b336b6ade7b247b722beea61a8cf10e30653745d187d26dcda3a2f2d38c04423315d20a67bc883c9e7b0d4686a759e379644cd457
+DIST marshmallow-3.13.0.tar.gz 175134 BLAKE2B fc8ffb87ba31d5bd56c7ebf655824f59c78cea257a1b59de8a97be9f380367d4db428b6f4f93f81140cccd8274fee7946e466f87f7c31b6b9d39d5bb9fba3104 SHA512 e4425bfa26609c80bc581b60be5554effe4a57eafc36338dc672cb0b42fc14d788a1ef3b4506b6429bf8d235e6edb10925173c8414b2abca12a4c7bb5496ed53
diff --git a/dev-python/marshmallow/marshmallow-3.13.0.ebuild b/dev-python/marshmallow/marshmallow-3.13.0.ebuild
new file mode 100644
index 000000000000..7d3435061f3f
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.13.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest