summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-09-14 17:54:10 -0700
committerZac Medico <zmedico@gentoo.org>2018-09-14 18:15:08 -0700
commit4da9bd56caa226e3e7738555bb360f7394c6985d (patch)
tree05dfcc583ff506c2bef92cfd80745c4f2645bb3d /dev-python/locustio/locustio-0.9.0.ebuild
parentdev-db/mysql: Drop old version of 5.5 (diff)
downloadgentoo-4da9bd56caa226e3e7738555bb360f7394c6985d.tar.gz
gentoo-4da9bd56caa226e3e7738555bb360f7394c6985d.tar.bz2
gentoo-4da9bd56caa226e3e7738555bb360f7394c6985d.zip
dev-python/locustio: version bump to 0.9.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-python/locustio/locustio-0.9.0.ebuild')
-rw-r--r--dev-python/locustio/locustio-0.9.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/locustio/locustio-0.9.0.ebuild b/dev-python/locustio/locustio-0.9.0.ebuild
new file mode 100644
index 000000000000..074ae16ed24d
--- /dev/null
+++ b/dev-python/locustio/locustio-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A python utility for doing easy, distributed load testing of a web site"
+HOMEPAGE="https://locust.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">=dev-python/gevent-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-16.0.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
+
+python_prepare_all() {
+ # allow useage of renamed msgpack
+ sed -i 's/"msgpack[^"]*"[, ]*//' setup.py || die
+ distutils-r1_python_prepare_all
+}