summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-28 08:24:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-28 08:53:45 +0200
commit383ddf710254f6e81c5f552d49a461cc49d717a6 (patch)
tree4feec30ddbd30eb67112add4f162c3edc9118ab8 /dev-python/kiwisolver
parentdev-python/prettytable: Bump to 2.2.0 (diff)
downloadgentoo-383ddf710254f6e81c5f552d49a461cc49d717a6.tar.gz
gentoo-383ddf710254f6e81c5f552d49a461cc49d717a6.tar.bz2
gentoo-383ddf710254f6e81c5f552d49a461cc49d717a6.zip
dev-python/kiwisolver: Bump to 1.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kiwisolver')
-rw-r--r--dev-python/kiwisolver/Manifest1
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.3.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/kiwisolver/Manifest b/dev-python/kiwisolver/Manifest
index 64dabc32e1cf..ce56ec80fc60 100644
--- a/dev-python/kiwisolver/Manifest
+++ b/dev-python/kiwisolver/Manifest
@@ -1 +1,2 @@
DIST kiwisolver-1.3.1.tar.gz 86948 BLAKE2B 4e03547842e831424aef5be880021aea8d0fef372900bcb9b55f2367fc89f728250b936702fd737807579be34e4ff7489d5669f5113e95612352a293d9f883ea SHA512 0f5c1e516c334d358b8679313035dd45386381965853005271c73e3f4421fb27e3ca5a43b4f2dc85d693f4151427dae9b34d372fe72fcc1a186abd85a54a225a
+DIST kiwisolver-1.3.2.tar.gz 89075 BLAKE2B 729880e3b18ac8c6c3e48d2fb32f00b4232118eb753f60837c7736c75a0f22e7a259aec46b76bc91286541847929eb4a92fcf9991650dea16d263f4d16beffc1 SHA512 e9ef20756df587b49f7b8e52ff388db6e2e551548ae7d60b6916586fb35249b10bda895a7be7635b300e6100ec1c7daf7d641de6d26d9b2c36055ac6c176302b
diff --git a/dev-python/kiwisolver/kiwisolver-1.3.2.ebuild b/dev-python/kiwisolver/kiwisolver-1.3.2.ebuild
new file mode 100644
index 000000000000..e337b6ffae01
--- /dev/null
+++ b/dev-python/kiwisolver/kiwisolver-1.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+# tagging fail?
+MY_PV=${PV}.rc1
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="https://github.com/nucleic/kiwi"
+SRC_URI="https://github.com/nucleic/kiwi/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/kiwi-${MY_PV}
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/cppy-1.1.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.1-darwin-build.patch"
+)
+
+distutils_enable_tests pytest