summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-25 13:20:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-25 13:20:53 +0200
commit7460b31f518138b7165f82d97d1c0ed8007a379e (patch)
treebeeca42331ec94bae72f2f5de107e3e474d3df41 /dev-python/elementpath
parentdev-python/hypothesis: Bump to 5.29.0 (diff)
downloadgentoo-7460b31f518138b7165f82d97d1c0ed8007a379e.tar.gz
gentoo-7460b31f518138b7165f82d97d1c0ed8007a379e.tar.bz2
gentoo-7460b31f518138b7165f82d97d1c0ed8007a379e.zip
dev-python/elementpath: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-2.0.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 27e8465efdf1..648c98ab3d68 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,2 +1,3 @@
DIST elementpath-1.4.6.tar.gz 121815 BLAKE2B 09014fc503c8a3a6a6865572fa48c515af19fc009512369d8e761ca5b4e516de1add7eb14c0681114331c4a8ef08cccb5fac8f4ce2b436523780cb4e41e2dc00 SHA512 ac1d7fc0ab07f22fa02550ac77f4067b5564f78619bf98d6fda257751d6404684622580002d69beb769fc471500ee0c08f6095b05ddc6b7d81276dc8e158c40b
DIST elementpath-2.0.0.tar.gz 149239 BLAKE2B 6963429ee127ef2a293da6706e6d1bc13be4d864d7da3d7169dd81d0a430156684f0977076182ec7aff7622940dbc341b84fab3eb488bbe6470476c4d30b6d4a SHA512 bb29c9cf30e9a414f9ddc7e29d3ae09af74302ed9c0bb98332b4fe01bab2e043cd5adb59b20a0730218d79b9f2ae42e9f2ad3ed7e4d0ae8ffde1800c96ee00a9
+DIST elementpath-2.0.1.tar.gz 186127 BLAKE2B db2e566e3032881d9db57d3951371dd4321baf3c3246a1a882c8a1ee9dafee2c2e4c2e8bb35cea7452ed51779a91c85976847cb46f18c1c6683c7c501961b2ed SHA512 77bf895c9d509dec57dd9770ebddf8ad58eca4aaee46c3372fead2d0a5109ff27e183d29a5bd5ef1a2ad203c6c64387b11b8bc0b2e96786843d24faadc3274ad
diff --git a/dev-python/elementpath/elementpath-2.0.1.ebuild b/dev-python/elementpath/elementpath-2.0.1.ebuild
new file mode 100644
index 000000000000..64b4b299f7fa
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath
+ https://pypi.org/project/elementpath/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest