summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 17:37:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 17:58:01 +0100
commitfac4e5e6f07591dfbeb13cb5c52cbc744ae45517 (patch)
treea736118aca0a1632448ed568da8c3cfd7cdb3ba2 /dev-python/BitVector
parentdev-python/APScheduler: PEP517, py3.11 (diff)
downloadgentoo-fac4e5e6f07591dfbeb13cb5c52cbc744ae45517.tar.gz
gentoo-fac4e5e6f07591dfbeb13cb5c52cbc744ae45517.tar.bz2
gentoo-fac4e5e6f07591dfbeb13cb5c52cbc744ae45517.zip
dev-python/BitVector: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/BitVector')
-rw-r--r--dev-python/BitVector/BitVector-3.5.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/BitVector/BitVector-3.5.0-r1.ebuild b/dev-python/BitVector/BitVector-3.5.0-r1.ebuild
new file mode 100644
index 000000000000..2c661fe0bf4b
--- /dev/null
+++ b/dev-python/BitVector/BitVector-3.5.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
+HOMEPAGE="
+ https://engineering.purdue.edu/kak/dist/
+ https://pypi.org/project/BitVector/
+"
+SRC_URI="https://engineering.purdue.edu/kak/dist/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${EPYTHON}" TestBitVector/Test.py || die "Tests fail with ${EPYTHON}"
+}