summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-27 16:41:54 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-27 16:42:24 +1300
commitf9c71bf8b9b3823a4d7500092412bc5831bf664b (patch)
treec9262d9ab51e157692f9521e317fe8ceac4af723 /dev-perl/XML-LibXSLT
parentdev-util/clinfo: Cleanup old versions (diff)
downloadgentoo-f9c71bf8b9b3823a4d7500092412bc5831bf664b.tar.gz
gentoo-f9c71bf8b9b3823a4d7500092412bc5831bf664b.tar.bz2
gentoo-f9c71bf8b9b3823a4d7500092412bc5831bf664b.zip
dev-perl/XML-LibXSLT: Bump to version 1.960.0
- Properly fix expanded entities test ( #623192 ) - Cleanup author tests Upstream: - Cease using $Config{libs} Bug: https://bugs.gentoo.org/623192 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/XML-LibXSLT')
-rw-r--r--dev-perl/XML-LibXSLT/Manifest1
-rw-r--r--dev-perl/XML-LibXSLT/XML-LibXSLT-1.960.0.ebuild31
-rw-r--r--dev-perl/XML-LibXSLT/files/XML-LibXSLT-1.96-entityexpandtest.patch29
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-perl/XML-LibXSLT/Manifest b/dev-perl/XML-LibXSLT/Manifest
index 6783923529d6..2523ea74bbc3 100644
--- a/dev-perl/XML-LibXSLT/Manifest
+++ b/dev-perl/XML-LibXSLT/Manifest
@@ -1,2 +1,3 @@
DIST XML-LibXSLT-1.94.tar.gz 114015 BLAKE2B e16cebbfc5e126dc56482845af4f21b70c62ef08eb14bc79f678fca35d418858b33d69adc411836f4d81cdb7dde8fb535b9f4855a947deab60ec1d77a4edd9d5 SHA512 52b3ec6ef0556d9dde8320acbea01fe36e219bc62ed2d9e0cbe2f8f402bfc3f42ca1e28a6e047e69f501982fe4ba40d23fcfbce9399388c9f28a0d8804fc5f73
DIST XML-LibXSLT-1.95.tar.gz 114231 BLAKE2B 792ceab8dd2e185c8c3c9a4a6981817ccb667006de588b9a8047eca8c27c63ed73e2aa5629314b723585fa2ca37f468bbacd2ff1d7596e9ca446aca56b412197 SHA512 06a1c9896a391be2588995f25520da05f086b3fa79109884131525a0d76a7b375e0c5a2febf8a79a888f3a9bd25b5eb39064de1baeffafcfe18f5576c9c54e19
+DIST XML-LibXSLT-1.96.tar.gz 114068 BLAKE2B 2225e387e9e877578be51a9a6c8c3612490e79c2cec366dd2fdc64710ce67200f5ab7109742197abcdc311f9a1bf16b42a40c7e7df4d669b638de4ee49782866 SHA512 7b6e22889c538bbd861c6420cd56893d229676d3afc1cf30e17cae48a4714139769a99a48a99f1dff52864f4989e410303007c07941625bf6bd12a24276c35e6
diff --git a/dev-perl/XML-LibXSLT/XML-LibXSLT-1.960.0.ebuild b/dev-perl/XML-LibXSLT/XML-LibXSLT-1.960.0.ebuild
new file mode 100644
index 000000000000..245d3796b38e
--- /dev/null
+++ b/dev-perl/XML-LibXSLT/XML-LibXSLT-1.960.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=1.96
+inherit perl-module
+
+DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-Encode
+ >=dev-perl/XML-LibXML-1.700.0
+ >=dev-libs/libxslt-1.1.28
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/pkgconfig
+"
+PERL_RM_FILES=(
+ "t/cpan-changes.t" "t/pod.t"
+ "t/style-trailing-space.t"
+)
+PATCHES=(
+ "${FILESDIR}/${PN}-1.96-entityexpandtest.patch"
+)
diff --git a/dev-perl/XML-LibXSLT/files/XML-LibXSLT-1.96-entityexpandtest.patch b/dev-perl/XML-LibXSLT/files/XML-LibXSLT-1.96-entityexpandtest.patch
new file mode 100644
index 000000000000..3826ba5dc5d3
--- /dev/null
+++ b/dev-perl/XML-LibXSLT/files/XML-LibXSLT-1.96-entityexpandtest.patch
@@ -0,0 +1,29 @@
+From a70778f1e263bce11b8749353a7a6a99e3f721fb Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 27 Mar 2018 16:00:45 +1300
+Subject: Force entity expansion
+
+Gentoo's XML::LibXML does not expand entities on its own by default
+and has to be configured to do so.
+
+Bug: https://bugs.gentoo.org/623192
+---
+ t/06entities.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/06entities.t b/t/06entities.t
+index 32bc395..3d5e791 100644
+--- a/t/06entities.t
++++ b/t/06entities.t
+@@ -9,7 +9,7 @@ use XML::LibXSLT;
+ my $parser = XML::LibXML->new();
+ my $xslt = XML::LibXSLT->new();
+
+-# $parser->expand_entities(1);
++$parser->expand_entities(1);
+
+ my $source = $parser->parse_string(qq{<?xml version="1.0" encoding="UTF-8"?>
+ <root>foo</root>});
+--
+2.16.2
+