summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Log-Dispatch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Log-Dispatch')
-rw-r--r--dev-perl/Log-Dispatch/Log-Dispatch-2.410.0.ebuild26
-rw-r--r--dev-perl/Log-Dispatch/Log-Dispatch-2.440.0.ebuild45
-rw-r--r--dev-perl/Log-Dispatch/Log-Dispatch-2.450.0.ebuild42
-rw-r--r--dev-perl/Log-Dispatch/Manifest3
-rw-r--r--dev-perl/Log-Dispatch/metadata.xml26
5 files changed, 142 insertions, 0 deletions
diff --git a/dev-perl/Log-Dispatch/Log-Dispatch-2.410.0.ebuild b/dev-perl/Log-Dispatch/Log-Dispatch-2.410.0.ebuild
new file mode 100644
index 000000000000..4da074869509
--- /dev/null
+++ b/dev-perl/Log-Dispatch/Log-Dispatch-2.410.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=Log-Dispatch
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=2.41
+inherit perl-module
+
+DESCRIPTION="Dispatches messages to multiple Log::Dispatch::* objects"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~ppc-aix"
+IUSE=""
+
+RDEPEND="
+ dev-perl/Params-Validate
+ dev-perl/Class-Load
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.31"
+
+SRC_TEST="do"
diff --git a/dev-perl/Log-Dispatch/Log-Dispatch-2.440.0.ebuild b/dev-perl/Log-Dispatch/Log-Dispatch-2.440.0.ebuild
new file mode 100644
index 000000000000..f8ff3069e5e3
--- /dev/null
+++ b/dev-perl/Log-Dispatch/Log-Dispatch-2.440.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=2.44
+inherit perl-module
+
+DESCRIPTION="Dispatches messages to multiple Log::Dispatch::* objects"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-aix"
+IUSE="ithreads test"
+# see bug 545998 about the use flag ithreads
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Devel-GlobalDestruction
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ dev-perl/Module-Runtime
+ dev-perl/Params-Validate
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Sys-Syslog-0.280.0
+ virtual/perl-threads-shared
+ ithreads? ( virtual/perl-threads )
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Requires
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Log-Dispatch/Log-Dispatch-2.450.0.ebuild b/dev-perl/Log-Dispatch/Log-Dispatch-2.450.0.ebuild
new file mode 100644
index 000000000000..f25be38dba87
--- /dev/null
+++ b/dev-perl/Log-Dispatch/Log-Dispatch-2.450.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=2.45
+inherit perl-module
+
+DESCRIPTION="Dispatches messages to multiple Log::Dispatch::* objects"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-aix"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Devel-GlobalDestruction
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ dev-perl/Module-Runtime
+ dev-perl/Params-Validate
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Sys-Syslog-0.280.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Requires
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Log-Dispatch/Manifest b/dev-perl/Log-Dispatch/Manifest
new file mode 100644
index 000000000000..c47be8d055ca
--- /dev/null
+++ b/dev-perl/Log-Dispatch/Manifest
@@ -0,0 +1,3 @@
+DIST Log-Dispatch-2.41.tar.gz 35285 SHA256 3f81fa068a2d68b0d13243a874da765ffb728a9d26ed44ef088ca627faa4556f SHA512 5ce6c1d9549583d6e8927a3e3bc1f4b2d37e7705edd10ea05039ea5fc12ea3b01b49cb9d863bccadb373e6522b973b5189125e2a91a824fdb5dbec2b5d9c6d7c WHIRLPOOL 92d6313adae51a1da0533638da0eb9e4e569aa2d6601d9b372e3eccc69bcb20fa1853e726548a663aa7cfc1251d9a2951ad83f66903a2cfdfb16409d51db82fe
+DIST Log-Dispatch-2.44.tar.gz 49540 SHA256 fe6c37b3fc28e3dc8ca15f7657d193c1db994e20153391506ca490a6afeef99c SHA512 2acaf327a440e00ba33e60da50db4c49b7ff8884ffc5dea0c033045367d1ab4cfb69ca81a2a08741ba80b347fd22238791bd758c37754154a5afa6311fa5a083 WHIRLPOOL dadb1409d7e3c39fb3faced517a9210a499a5024254963c6c3788fe98edd11820a24d8d544c0df3ad5f57daca53dcab96f4ac88bc37b4aa9f8d04765820b0898
+DIST Log-Dispatch-2.45.tar.gz 52537 SHA256 707fc17d1f072150b87d400e5994b46ae2083a7120a9d21d37680ade08084bd6 SHA512 c4b82c408ffa8b5b9681b8b3eea90dc2cb95639a65f568ca977068bf30b087f7e29fdc2a80216770e07774c39744fbf6810faeac4786a3a183764bbe15d70f76 WHIRLPOOL 6e9043477bed42afa6412e2cfc2c0330ad2971edd88fb781f8c4a1b27254bd1162d651e752aab6c0563786721975ac0c4a8ce42a93d536925b882eda08149141
diff --git a/dev-perl/Log-Dispatch/metadata.xml b/dev-perl/Log-Dispatch/metadata.xml
new file mode 100644
index 000000000000..9b90201f2082
--- /dev/null
+++ b/dev-perl/Log-Dispatch/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Log-Dispatch</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::ApacheLog</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Base</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Email</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Email::MIMELite</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Email::MailSend</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Email::MailSender</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Email::MailSendmail</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::File</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::File::Locked</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Handle</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Null</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Output</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Screen</remote-id>
+ <remote-id type="cpan-module">Log::Dispatch::Syslog</remote-id>
+ </upstream>
+ <use>
+ <flag name='ithreads'>Ensure perl is built with threads for Syslog 'lock' feature</flag>
+ </use>
+</pkgmetadata>