summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-07-07 12:23:57 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-07-09 10:54:28 +0300
commitf1bbe799e8f7ed31a8a6bc2c6651215bf9d06fac (patch)
tree1a96cee390e3e4ee2c13bfa6120b7ba917431668 /dev-lua
parentdev-lua/luasocket: new maintainer (diff)
downloadgentoo-f1bbe799e8f7ed31a8a6bc2c6651215bf9d06fac.tar.gz
gentoo-f1bbe799e8f7ed31a8a6bc2c6651215bf9d06fac.tar.bz2
gentoo-f1bbe799e8f7ed31a8a6bc2c6651215bf9d06fac.zip
dev-lua/luasocket: install headers
Install headers needed for other packages. Bug: https://bugs.gentoo.org/730352 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16527 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luasocket/luasocket-3.0_rc1-r5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-lua/luasocket/luasocket-3.0_rc1-r5.ebuild b/dev-lua/luasocket/luasocket-3.0_rc1-r5.ebuild
new file mode 100644
index 000000000000..5ed5cbf52040
--- /dev/null
+++ b/dev-lua/luasocket/luasocket-3.0_rc1-r5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib multilib-minimal flag-o-matic toolchain-funcs
+
+DESCRIPTION="Networking support library for the Lua language"
+HOMEPAGE="http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/
+ https://github.com/diegonehab/luasocket"
+SRC_URI="https://github.com/diegonehab/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/lua-5.1.5-r2:0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}-${PV/_/-}
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/proxy-fix.patch
+)
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ LD="$(tc-getCC) ${LDFLAGS}"\
+ $(usex debug DEBUG="DEBUG" "")
+}
+
+multilib_src_install() {
+ local luav=$($(tc-getPKG_CONFIG) --variable V lua)
+ emake \
+ DESTDIR="${D}" \
+ LUAPREFIX_linux=/usr \
+ LUAV=${luav} \
+ CDIR_linux=$(get_libdir)/lua/${luav} \
+ install-unix
+ insinto /usr/include/lua${luav}/luasocket
+ doins src/*.h
+}
+
+multilib_src_install_all() {
+ dodoc NEW README
+ docinto html
+ dodoc -r doc/.
+}