summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-01-07 18:12:37 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-01-17 10:39:41 +0100
commit96ebc7668078e276d7f4c520081c8d1e44438843 (patch)
tree1377c2933aca0c5cea5c719a1ece87dc161bc808 /dev-java
parentsec-keys/openpgp-keys-apache-httpcomponents-commons: new package, add 20220903 (diff)
downloadgentoo-96ebc7668078e276d7f4c520081c8d1e44438843.tar.gz
gentoo-96ebc7668078e276d7f4c520081c8d1e44438843.tar.bz2
gentoo-96ebc7668078e276d7f4c520081c8d1e44438843.zip
dev-java/aspectj: depend on jakarta-regexp
Changes dependency from ant-apache-regexp to jakarta-regexp which provides the needed org.apache.regexp without using an ant-task. This change is needed fur upcoming >=dev-java/ant-1.10.14 in order to avoid a cyclic dependency. Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/34814 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/aspectj/aspectj-1.9.7-r1.ebuild (renamed from dev-java/aspectj/aspectj-1.9.7.ebuild)10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-java/aspectj/aspectj-1.9.7.ebuild b/dev-java/aspectj/aspectj-1.9.7-r1.ebuild
index 4f7ef2231ed2..e3b7c408c182 100644
--- a/dev-java/aspectj/aspectj-1.9.7.ebuild
+++ b/dev-java/aspectj/aspectj-1.9.7-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="A seamless aspect-oriented extension to the Java programming language"
HOMEPAGE="https://eclipse.org/aspectj/"
-SRC_URI="https://github.com/eclipse/org.aspectj/archive/refs/tags/V${PV//./_}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/eclipse-aspectj/aspectj/archive/V${PV//./_}.tar.gz -> ${P}.tar.gz"
LICENSE="EPL-1.0"
SLOT="0"
@@ -16,7 +16,7 @@ KEYWORDS="amd64 x86"
CDEPEND="dev-java/asm:9
dev-java/commons-logging:0
- dev-java/ant-apache-regexp:0"
+ dev-java/jakarta-regexp:1.4"
DEPEND="${CDEPEND}
>=virtual/jdk-1.8:*"
RDEPEND="${CDEPEND}
@@ -26,7 +26,7 @@ BDEPEND="app-arch/zip"
S=${WORKDIR}/org.${P//./_}
JAVA_GENTOO_CLASSPATH_EXTRA="aspectjweaver.jar"
-JAVA_GENTOO_CLASSPATH="commons-logging,asm-9,ant-apache-regexp"
+JAVA_GENTOO_CLASSPATH="commons-logging,asm-9,jakarta-regexp-1.4"
JAVA_ENCODING="iso8859-1"
src_compile() {