summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/xerces
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/xerces')
-rw-r--r--dev-java/xerces/Manifest2
-rw-r--r--dev-java/xerces/files/xerces-1.3.1-build.xml64
-rw-r--r--dev-java/xerces/files/xerces-2.11.0-build.xml.patch46
-rw-r--r--dev-java/xerces/files/xerces-2.3.0-gentoo.patch61
-rw-r--r--dev-java/xerces/files/xerces-2.9.0-gentoo.patch21
-rw-r--r--dev-java/xerces/files/xerces-2.9.0-no_dom3.patch20
-rw-r--r--dev-java/xerces/files/xerces-2.9.1-gentoo.patch21
-rw-r--r--dev-java/xerces/files/xerces-2.9.1-no_dom3.patch20
-rw-r--r--dev-java/xerces/metadata.xml5
-rw-r--r--dev-java/xerces/xerces-1.3.1-r2.ebuild39
-rw-r--r--dev-java/xerces/xerces-2.11.0.ebuild59
11 files changed, 358 insertions, 0 deletions
diff --git a/dev-java/xerces/Manifest b/dev-java/xerces/Manifest
new file mode 100644
index 000000000000..ac71250fc674
--- /dev/null
+++ b/dev-java/xerces/Manifest
@@ -0,0 +1,2 @@
+DIST Xerces-J-src.1.3.1.tar.gz 900263 SHA256 d59f57ef4ec540f75b4b79aeef20e85ccb4f2c3b516dc995f1fc88f526f5f1e1 SHA512 2a7990a63d0ff3c491af4e5d7480583378dbcd8ce6042d4be6e87e53aa1012f2f0e709e7e0cde1ec9b930822a1e386550a899a1ef29a01267806dbfe595a9d64 WHIRLPOOL ecc7abc65c6b22e8e749e5f2ccc5b45d3b99d0439f2a020cfda2c4db5958ce66df743a978df475ee855f07129c8ef801d2c8cd97635738c1df404873d4287e9a
+DIST Xerces-J-src.2.11.0.tar.gz 1792762 SHA256 f59a5ef7b51bd883f2e9bda37a9360692e6c5e439b98d9b6ac1953e1f98b0680 SHA512 de2a3045f9aa87386527ab4055f1681ed85addee3a35b4fe344fc7b93e60d7db051df636c732172256ed130cf3055dc01940cd2106a8046aa06ee6e14e5b0411 WHIRLPOOL 891a1a04dd781c3dd4c01f295679b069dca9ae7126b3a4e3ab0e9da8ae6bd00e62e97b606acb233d3cd7b0da21012a6aa4f8339b42d26e251440d01057d24973
diff --git a/dev-java/xerces/files/xerces-1.3.1-build.xml b/dev-java/xerces/files/xerces-1.3.1-build.xml
new file mode 100644
index 000000000000..d688a62057ce
--- /dev/null
+++ b/dev-java/xerces/files/xerces-1.3.1-build.xml
@@ -0,0 +1,64 @@
+<?xml version="1.0"?>
+
+<project name="xerces" default="jar">
+ <!-- some properties -->
+ <property name="src.dir" value="src" />
+ <property name="build.dir" value="build" />
+ <property name="docs.dir" value="docs" />
+ <property name="dist.dir" value="dist" />
+ <property name="jarfile" value="${dist.dir}/xerces.jar" />
+ <property name="target.jdk" value="1.3" />
+
+ <!-- init -->
+ <target name="init">
+ <mkdir dir="${dist.dir}" />
+ <mkdir dir="${build.dir}" />
+ <mkdir dir="${docs.dir}" />
+ </target>
+
+ <!-- compile everything -->
+ <target name="compile" depends="init">
+ <mkdir dir="${build.dir}" />
+ <javac srcdir="${src.dir}"
+ destdir="${build.dir}"
+ source="${target.jdk}"
+ target="${target.jdk}" />
+
+ <copy todir="${build.dir}">
+ <fileset dir="${src.dir}">
+ <exclude name="**/*.java" />
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- build the jar file -->
+ <target name="jar" depends="compile">
+ <jar jarfile="${jarfile}" basedir="${build.dir}" />
+ </target>
+
+ <!-- generate javadocs -->
+ <target name="docs" depends="init">
+ <javadoc sourcepath="${src.dir}"
+ packagenames="org.* , javax.*"
+ destdir="${docs.dir}"
+ author="true"
+ version="true"
+ use="true"
+ windowtitle="${ant.project.name} API" />
+ </target>
+
+ <!-- clean up -->
+ <target name="clean">
+ <delete dir="${build.dir}" />
+ <delete dir="${docs.dir}" />
+ <delete dir="${dist.dir}" />
+ </target>
+
+ <!-- zip the sources -->
+ <target name="sourcezip">
+ <zip destfile="${dist.dir}/${ant.project.name}-src.zip">
+ <zipfileset dir="${src.dir}" />
+ </zip>
+ </target>
+
+</project>
diff --git a/dev-java/xerces/files/xerces-2.11.0-build.xml.patch b/dev-java/xerces/files/xerces-2.11.0-build.xml.patch
new file mode 100644
index 000000000000..61afcddad9a4
--- /dev/null
+++ b/dev-java/xerces/files/xerces-2.11.0-build.xml.patch
@@ -0,0 +1,46 @@
+Author: Ralph Sennhauser <sera@gentoo.org>
+
+Don't reference non existing jar in taskdef. #351394
+Don't let user properties leak into build env.
+Don't bundle stuff from xml-commons-external.
+
+--- a/build.xml
++++ b/build.xml
+@@ -39,18 +39,13 @@ Authors:
+ <property name="tools.dir" value="./tools"/>
+
+ <!-- enable compilation under JDK 1.4 and above -->
+- <taskdef name="xjavac" classname="org.apache.xerces.util.XJavac">
+- <classpath>
+- <pathelement location="${tools.dir}/bin/xjavac.jar"/>
+- </classpath>
+- </taskdef>
++ <taskdef name="xjavac" classname="org.apache.xerces.util.XJavac"/>
+
+ <!-- Allow properties following these statements to be overridden -->
+ <!-- Note that all of these don't have to exist. They've just been defined
+ incase they are used. -->
+ <property file="build.properties"/>
+ <property file=".ant.properties"/>
+- <property file="${user.home}/.ant.properties"/>
+ <property file="default.properties"/>
+
+ <target name="init">
+@@ -247,7 +242,7 @@ Authors:
+ <copy file="${src.dir}/org/apache/xerces/impl/xpath/regex/message.properties"
+ tofile="${build.src}/org/apache/xerces/impl/xpath/regex/message_en.properties"/>
+
+- <!-- now deal with API's: -->
++ <!-- now deal with API's:
+ <unzip src="${src.apis.zip}" dest="${build.src}">
+ <patternset
+ includes="org/xml/sax/**
+@@ -269,7 +264,7 @@ Authors:
+ org/w3c/dom/views/**
+ org/w3c/dom/xpath/**"
+ />
+- </unzip>
++ </unzip> -->
+
+ <!-- substitute tokens as needed -->
+ <replace file="${build.dir}/src/org/apache/xerces/impl/Version.java"
diff --git a/dev-java/xerces/files/xerces-2.3.0-gentoo.patch b/dev-java/xerces/files/xerces-2.3.0-gentoo.patch
new file mode 100644
index 000000000000..08f95ed7a6fa
--- /dev/null
+++ b/dev-java/xerces/files/xerces-2.3.0-gentoo.patch
@@ -0,0 +1,61 @@
+diff -urpN xerces-2_3_0.orig/build.sh xerces-2_3_0/build.sh
+--- xerces-2_3_0.orig/build.sh 2005-01-15 15:14:51.682424232 +0100
++++ xerces-2_3_0/build.sh 2005-01-15 16:22:11.299309120 +0100
+@@ -19,7 +19,7 @@ uname | grep WIN && CLPATHSEP=\;
+
+ # Keep this classpath to the minimum required to run ant
+ # Application dependent classpaths are specified in build.xml
+-LOCALCLASSPATH="$JAVA_HOME/lib/tools.jar${CLPATHSEP}${JAVA_HOME}/lib/classes.zip${CLPATHSEP}./tools/ant.jar${CLPATHSEP}./tools/xercesImpl.jar${CLPATHSEP}./tools/xml-apis.jar${CLPATHSEP}./tools/bin/xjavac.jar"
++LOCALCLASSPATH="$JAVA_HOME/lib/tools.jar${CLPATHSEP}${JAVA_HOME}/lib/classes.zip${CLPATHSEP}./tools/ant.jar${CLPATHSEP}./tools/ant-launcher.jar${CLPATHSEP}./tools/xercesImpl.jar${CLPATHSEP}./tools/xml-apis.jar${CLPATHSEP}./tools/bin/xjavac.jar"
+ ANT_HOME=./tools
+
+ echo Building with classpath \"$LOCALCLASSPATH\"
+diff -urpN xerces-2_3_0.orig/build.xml xerces-2_3_0/build.xml
+--- xerces-2_3_0.orig/build.xml 2005-01-15 15:14:51.682424232 +0100
++++ xerces-2_3_0/build.xml 2005-01-15 16:38:48.751673312 +0100
+@@ -173,7 +173,6 @@ Copyright:
+ <copy file="${src.dir}/org/apache/xerces/parsers/org.apache.xerces.xni.parser.XMLParserConfiguration"
+ tofile="${build.dest}/META-INF/services/org.apache.xerces.xni.parser.XMLParserConfiguration"/>
+
+- <!-- copy src files -->
+ <copy todir="${build.src}">
+ <fileset
+ dir="${src.dir}"
+@@ -187,8 +186,8 @@ Copyright:
+ org/apache/xerces/dom3/ls/**">
+ </fileset>
+ </copy>
+-
+- <!-- now deal with API's: -->
++
++ <!-- now deal with API's:
+ <unzip src="${src.apis.zip}" dest="${build.src}">
+ <patternset
+ includes="org/xml/sax/**
+@@ -200,7 +199,7 @@ Copyright:
+ org/w3c/dom/traversal/**"
+ />
+ </unzip>
+-
++ -->
+ <!-- substitute tokens as needed -->
+ <replace file="${build.dir}/src/org/apache/xerces/impl/Version.java"
+ token="@@VERSION@@" value="${parser.Name} ${parser.Version}"/>
+@@ -221,16 +220,7 @@ Copyright:
+ debug="${debug}"
+ deprecation="${deprecation}"
+ optimize="${optimize}"
+- includeAntRuntime="false"
+- includeJavaRuntime="false"
+- excludes="org/xml/sax/**
+- javax/xml/parsers/**
+- org/w3c/dom/*
+- org/w3c/dom/events/**
+- org/w3c/dom/html/**
+- org/w3c/dom/ranges/**
+- org/w3c/dom/traversal/**"
+- />
++ classpath="tools/xml-apis.jar" />
+ </target>
+
+ <!-- =================================================================== -->
diff --git a/dev-java/xerces/files/xerces-2.9.0-gentoo.patch b/dev-java/xerces/files/xerces-2.9.0-gentoo.patch
new file mode 100644
index 000000000000..61445ea6fe88
--- /dev/null
+++ b/dev-java/xerces/files/xerces-2.9.0-gentoo.patch
@@ -0,0 +1,21 @@
+diff -urpN xerces-2_6_2.old/build.xml xerces-2_6_2/build.xml
+--- xerces-2_6_2.old/build.xml 2004-02-20 19:58:14.000000000 +0100
++++ xerces-2_6_2/build.xml 2005-01-15 14:41:08.603978904 +0100
+@@ -190,7 +190,7 @@ Copyright:
+ </fileset>
+ </copy>
+
+- <!-- now deal with API's: -->
++ <!-- now deal with API's:
+ <unzip src="${src.apis.zip}" dest="${build.src}">
+ <patternset
+ includes="org/xml/sax/**
+@@ -202,7 +202,7 @@ Copyright:
+ org/w3c/dom/traversal/**"
+ />
+ </unzip>
+-
++ -->
+ <!-- substitute tokens as needed -->
+ <replace file="${build.dir}/src/org/apache/xerces/impl/Version.java"
+ token="@@VERSION@@" value="${parser.Name} ${parser.Version}"/>
diff --git a/dev-java/xerces/files/xerces-2.9.0-no_dom3.patch b/dev-java/xerces/files/xerces-2.9.0-no_dom3.patch
new file mode 100644
index 000000000000..8f485adcdbfd
--- /dev/null
+++ b/dev-java/xerces/files/xerces-2.9.0-no_dom3.patch
@@ -0,0 +1,20 @@
+diff -ru xerces-2_7_1/build.xml xerces-2_7_1-patched/build.xml
+--- xerces-2_7_1/build.xml 2005-07-26 16:09:07.000000000 -0400
++++ xerces-2_7_1-patched/build.xml 2005-12-08 23:51:32.000000000 -0500
+@@ -442,16 +442,6 @@
+ additionalparam='${additional.param}'
+ />
+ <mkdir dir='${build.dir}/docs/javadocs/other'/>
+- <javadoc packagenames='org.apache.html.*,
+- org.apache.wml.*,
+- org.apache.xml.serialize.*'
+- locale='en_US'
+- sourcepath='${build.src}' destdir='${build.dir}/docs/javadocs/other'
+- author='true' version='true'
+- windowtitle='Other Classes' doctitle='Other Classes'
+- bottom='${copyright}'
+- additionalparam='${additional.param}'
+- />
+ </target>
+
+ <!-- =================================================================== -->
diff --git a/dev-java/xerces/files/xerces-2.9.1-gentoo.patch b/dev-java/xerces/files/xerces-2.9.1-gentoo.patch
new file mode 100644
index 000000000000..61445ea6fe88
--- /dev/null
+++ b/dev-java/xerces/files/xerces-2.9.1-gentoo.patch
@@ -0,0 +1,21 @@
+diff -urpN xerces-2_6_2.old/build.xml xerces-2_6_2/build.xml
+--- xerces-2_6_2.old/build.xml 2004-02-20 19:58:14.000000000 +0100
++++ xerces-2_6_2/build.xml 2005-01-15 14:41:08.603978904 +0100
+@@ -190,7 +190,7 @@ Copyright:
+ </fileset>
+ </copy>
+
+- <!-- now deal with API's: -->
++ <!-- now deal with API's:
+ <unzip src="${src.apis.zip}" dest="${build.src}">
+ <patternset
+ includes="org/xml/sax/**
+@@ -202,7 +202,7 @@ Copyright:
+ org/w3c/dom/traversal/**"
+ />
+ </unzip>
+-
++ -->
+ <!-- substitute tokens as needed -->
+ <replace file="${build.dir}/src/org/apache/xerces/impl/Version.java"
+ token="@@VERSION@@" value="${parser.Name} ${parser.Version}"/>
diff --git a/dev-java/xerces/files/xerces-2.9.1-no_dom3.patch b/dev-java/xerces/files/xerces-2.9.1-no_dom3.patch
new file mode 100644
index 000000000000..8f485adcdbfd
--- /dev/null
+++ b/dev-java/xerces/files/xerces-2.9.1-no_dom3.patch
@@ -0,0 +1,20 @@
+diff -ru xerces-2_7_1/build.xml xerces-2_7_1-patched/build.xml
+--- xerces-2_7_1/build.xml 2005-07-26 16:09:07.000000000 -0400
++++ xerces-2_7_1-patched/build.xml 2005-12-08 23:51:32.000000000 -0500
+@@ -442,16 +442,6 @@
+ additionalparam='${additional.param}'
+ />
+ <mkdir dir='${build.dir}/docs/javadocs/other'/>
+- <javadoc packagenames='org.apache.html.*,
+- org.apache.wml.*,
+- org.apache.xml.serialize.*'
+- locale='en_US'
+- sourcepath='${build.src}' destdir='${build.dir}/docs/javadocs/other'
+- author='true' version='true'
+- windowtitle='Other Classes' doctitle='Other Classes'
+- bottom='${copyright}'
+- additionalparam='${additional.param}'
+- />
+ </target>
+
+ <!-- =================================================================== -->
diff --git a/dev-java/xerces/metadata.xml b/dev-java/xerces/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/xerces/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/xerces/xerces-1.3.1-r2.ebuild b/dev-java/xerces/xerces-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..2f50c144f299
--- /dev/null
+++ b/dev-java/xerces/xerces-1.3.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+S=${WORKDIR}/xerces-${PV//./_}
+DESCRIPTION="The next generation of high performance, fully compliant XML parsers in the Apache Xerces family"
+HOMEPAGE="http://xml.apache.org/xerces2-j/index.html"
+SRC_URI="http://archive.apache.org/dist/xml/xerces-j/old_xerces1/Xerces-J-src.${PV}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="1.3"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/xalan-2.5.2"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ cp "${FILESDIR}/${P}-build.xml" build.xml || die
+}
+
+EANT_DOC_TARGET="docs"
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ dodoc README STATUS || die
+ dohtml Readme.html || die
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc "${S}/src/org"
+}
diff --git a/dev-java/xerces/xerces-2.11.0.ebuild b/dev-java/xerces/xerces-2.11.0.ebuild
new file mode 100644
index 000000000000..2776621deb10
--- /dev/null
+++ b/dev-java/xerces/xerces-2.11.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils versionator java-pkg-2 java-ant-2
+
+DIST_PN="Xerces-J"
+SRC_PV="$(replace_all_version_separators _ )"
+DESCRIPTION="The next generation of high performance, fully compliant XML parsers in the Apache Xerces family"
+HOMEPAGE="http://xml.apache.org/xerces2-j/index.html"
+SRC_URI="mirror://apache/${PN}/j/${DIST_PN}-src.${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# they are missing from the upstream tarball"
+RESTRICT="test"
+
+COMMON_DEP="
+ dev-java/xml-commons-external:1.4
+ >=dev-java/xml-commons-resolver-1.2:0"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4
+ >=dev-java/xjavac-20110814:1"
+
+S="${WORKDIR}/${PN}-${SRC_PV}"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+JAVA_ANT_CLASSPATH_TAGS+=" javadoc"
+
+EANT_ANT_TASKS="xjavac-1"
+EANT_GENTOO_CLASSPATH="xml-commons-resolver,xml-commons-external-1.4"
+EANT_DOC_TARGET="javadocs"
+# known small bug - javadocs use custom taglets, which come as bundled jar in
+# xerces-J-tools.${PV}.tar.gz. Should find the taglets source instead.
+EANT_EXTRA_ARGS="-Dadditional.param="
+
+src_install() {
+ java-pkg_dojar build/xercesImpl.jar
+
+ dodoc README NOTICE
+ dohtml Readme.html
+
+ use doc && java-pkg_dojavadoc build/docs/javadocs/xerces2
+ use examples && java-pkg_doexamples samples
+ use source && java-pkg_dosrc src/org
+}