summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 09:54:36 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:34 +0100
commit2adc5357d6ce6fbd9bf1b2b328d6b65bdb822928 (patch)
tree3ebdb19237537616b708c550990a3617d5332ed2 /dev-haskell/authenticate
parentdev-haskell/html-conduit: bump up to 1.3.2.1 (diff)
downloadgentoo-2adc5357d6ce6fbd9bf1b2b328d6b65bdb822928.tar.gz
gentoo-2adc5357d6ce6fbd9bf1b2b328d6b65bdb822928.tar.bz2
gentoo-2adc5357d6ce6fbd9bf1b2b328d6b65bdb822928.zip
dev-haskell/authenticate: bump up to 1.3.5
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/authenticate')
-rw-r--r--dev-haskell/authenticate/Manifest1
-rw-r--r--dev-haskell/authenticate/authenticate-1.3.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/authenticate/Manifest b/dev-haskell/authenticate/Manifest
index 7afee192e984..2f481265cb14 100644
--- a/dev-haskell/authenticate/Manifest
+++ b/dev-haskell/authenticate/Manifest
@@ -1,3 +1,4 @@
DIST authenticate-1.3.2.11.tar.gz 8728 BLAKE2B 5c2a319ed40dc4b5cacfb7f5824e240cc9f60b95db6aca45b5ebfc6974f6bdd228386b889bf7eba65850dca88ef0c0d00e67e17aa75bc6308838a446e256c8bc SHA512 8e1358bd6dd62f10b372fd5df6bd2b50f1c161ade466316efa9e036c17be97e7c561eab968a2e17d28cc12988db454618bf11b8c9bc5e9a20d864423756eccb5
DIST authenticate-1.3.3.1.tar.gz 8703 BLAKE2B cfeb564029efa9ffceac72dcf9f506feeefe5cdf4c133785f55d71659ff398248f1ce286db8585c93039f6b03c291892e8df8fb110db5a5c8f5d2424acb45332 SHA512 e2caa227dfc4a4878ac7011d79d98c539320cb2fe5d9e260a9c71951486ba8af396fbcd0ccf3cb80205063881c7922f3d1a62d693ff8e1529b88e3cfc2e3c5c8
DIST authenticate-1.3.3.2.tar.gz 8785 BLAKE2B 43307b9551e9894805a26bced9aeeda87464bfd9e92666a329a3c424afdf6bae74e03262316d98a97b45bfda74369287e8b9e766e9b4f8dc9919294fd3b7a811 SHA512 98fd1e5fde51c9e2db10c9d22429d8c51914f28ec8493457a77afa5a9dc41a8e9920b27583d5aac9752a3b39561713f87489043c552396d132c75139a8e46927
+DIST authenticate-1.3.5.tar.gz 8817 BLAKE2B cfd9a4e9f8a6d4f76cb3c3e1e496c8eafbc5b675cc14b38463bb4175d3bcab86d1561a3434f6638062905e9bf3543f689cae5b4510283bb4da3c513a56014510 SHA512 12962fcf71c732a7e709e7069d46691917b9ee9f2af6aab5556b76a4556b6ffc39e52082a4fcdbe501c2cbc7cc496b1164b6a9f2c3883597fcdd0a8298d4ac1a
diff --git a/dev-haskell/authenticate/authenticate-1.3.5.ebuild b/dev-haskell/authenticate/authenticate-1.3.5.ebuild
new file mode 100644
index 000000000000..5f168e7885e2
--- /dev/null
+++ b/dev-haskell/authenticate/authenticate-1.3.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Authentication methods for Haskell web applications"
+HOMEPAGE="https://github.com/yesodweb/authenticate"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ >=dev-haskell/conduit-0.5:=[profile?]
+ >=dev-haskell/html-conduit-1.3:=[profile?]
+ >=dev-haskell/http-conduit-1.5:=[profile?]
+ >=dev-haskell/http-types-0.6:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/xml-conduit-1.0:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}