summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2022-03-18 15:52:03 +0000
committerSam James <sam@gentoo.org>2022-03-21 23:41:56 +0000
commitbd7dc288fa2238bd26218add1dab04b61901b2a6 (patch)
tree6fe2ceaa197d01a32a6cd0437f364a95e2b0d51a /dev-cpp
parentdev-cpp/asio: drop old (diff)
downloadgentoo-bd7dc288fa2238bd26218add1dab04b61901b2a6.tar.gz
gentoo-bd7dc288fa2238bd26218add1dab04b61901b2a6.tar.bz2
gentoo-bd7dc288fa2238bd26218add1dab04b61901b2a6.zip
dev-cpp/asio: version 1.22.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://bugs.gentoo.org/828648 Closes: https://github.com/gentoo/gentoo/pull/24649 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.22.1.ebuild63
-rw-r--r--dev-cpp/asio/files/asio-1.22.1-cpp20ex.patch29
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index e1e692858879..06d0aa659bbd 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,2 +1,3 @@
DIST asio-1.10.8.tar.bz2 1270332 BLAKE2B 97e4a6a7c8b4562f10af1d122e9b08c12d567fd0447d1951a907f47f77832dcd42df4cb9b5b392feaaa2ea7c79d8bedfcf12e3052957ec012d8bb6b4d1347eb5 SHA512 d870686d2b19bec9925c311f2f0fd370e9797bbad252176a80a998f9c322ecd502b5081826105712e7caf87c03c3e6b70a0e219019e5bff46077d6e8c3c6db09
DIST asio-1.21.0.tar.bz2 1967398 BLAKE2B 95e0ba44910e7450e614011b487acac0cd292302c0f502ec678639b70af7e6f9b86ee2c50c7f7e3e3437ce4474323e44b5e371c08f3a9ed464ffb3f428de728b SHA512 62252b2d3ca4fb99579c5fe57bf64b700792198dd7fa45acb4af7f64e83494bade1885b848f9e364f4c42d9db025841324cbd9a0fd3fe45526e7e4be6f60f8c0
+DIST asio-1.22.1.tar.bz2 3085878 BLAKE2B 07326a2273d5b8c0aef8402c92a6a88abbcb961d2a029596d58735d6626279e6d4d591371cc368a41fac1d0161b8786174ba71153e73aac38fa81a83f5f5be86 SHA512 be4a066d9f73662f68a771f63a59fc2e16e8ee1ae1ca6c581e09922514029e58c479edfc0517ee6b29a1fd377d202a2a6eb80d9d17f6e957233c11331f04a479
diff --git a/dev-cpp/asio/asio-1.22.1.ebuild b/dev-cpp/asio/asio-1.22.1.ebuild
new file mode 100644
index 000000000000..1917fccbef79
--- /dev/null
+++ b/dev-cpp/asio/asio-1.22.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/boost
+ dev-libs/openssl
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cpp20ex.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ # Make links to the example .cpp files work
+ # https://bugs.gentoo.org/828648
+ if use doc; then
+ dosym ../examples /usr/share/doc/${PF}/src/examples
+ fi
+ fi
+}
diff --git a/dev-cpp/asio/files/asio-1.22.1-cpp20ex.patch b/dev-cpp/asio/files/asio-1.22.1-cpp20ex.patch
new file mode 100644
index 000000000000..55de22b8a136
--- /dev/null
+++ b/dev-cpp/asio/files/asio-1.22.1-cpp20ex.patch
@@ -0,0 +1,29 @@
+The cpp20 dir doesn't exist
+https://github.com/chriskohlhoff/asio/issues/1026
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -15,7 +15,6 @@ EXAMPLES_CPP17 = examples/cpp17
+ endif
+
+ if HAVE_CXX20
+-EXAMPLES_CPP20 = examples/cpp20
+ endif
+
+ SUBDIRS = \
+@@ -23,7 +22,6 @@ SUBDIRS = \
+ $(EXAMPLES_CPP11) \
+ $(EXAMPLES_CPP14) \
+ $(EXAMPLES_CPP17) \
+- $(EXAMPLES_CPP20) \
+ tests
+
+ DIST_SUBDIRS = examples/cpp03 examples/cpp11 examples/cpp14 examples/cpp17 tests
+--- a/configure.ac
++++ b/configure.ac
+@@ -241,4 +241,4 @@ AC_OUTPUT([
+ src/examples/cpp11/Makefile
+ src/examples/cpp14/Makefile
+ src/examples/cpp17/Makefile
+- src/examples/cpp20/Makefile])
++ ])