summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/gitv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/gitv')
-rw-r--r--app-vim/gitv/Manifest2
-rw-r--r--app-vim/gitv/gitv-1.2.ebuild18
-rw-r--r--app-vim/gitv/gitv-1.3.ebuild18
-rw-r--r--app-vim/gitv/gitv-9999.ebuild23
-rw-r--r--app-vim/gitv/metadata.xml8
5 files changed, 69 insertions, 0 deletions
diff --git a/app-vim/gitv/Manifest b/app-vim/gitv/Manifest
new file mode 100644
index 000000000000..aa8b4b999eaf
--- /dev/null
+++ b/app-vim/gitv/Manifest
@@ -0,0 +1,2 @@
+DIST gitv-1.2.tar.gz 20449 SHA256 b848c03841539c3f3cc68fd42033038efee0194127d435eddba4b33ffec4b11c SHA512 97d45ecc9d56246a69169c94b2004a4e3bcbd417fdcd25f05e76394c92968350371e516cbe72a7e0f750117a5632b0b283e3e9bf0df387b2681ece8313ef9888 WHIRLPOOL ba1e75ba4e8a91d26b346f71059b6d820c49c1ac02e006e4ddca8231a55818c314aeff0df5b52374e634c533f446d9f3c93d95f73be0afef001c1b2de9ac30a0
+DIST gitv-1.3.tar.gz 21319 SHA256 6533196f9f2688846c7f4035ab1af82713f5e0e4aaf5c18335fa5007e0ad6555 SHA512 1a13d98ae9dd3e50a559d98881b6b0a8150186573e8f9fcdd9bd5cfdba1a679ea1c02b57f7d7be712dbfb5ec1bffbc4c0e8e1330cd64acf095c88400c499bfaf WHIRLPOOL 7c99b3e697c1e92ae829ad75a85ff2c777014420ed986a93d9d23a7df96af082d0c8c8a35949b1075fcbf8a754c203dd3055e787df075352f9d0fcafce199257
diff --git a/app-vim/gitv/gitv-1.2.ebuild b/app-vim/gitv/gitv-1.2.ebuild
new file mode 100644
index 000000000000..b5c1475b48c3
--- /dev/null
+++ b/app-vim/gitv/gitv-1.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3574"
+SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86 ~ppc-macos"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="dev-vcs/git
+ app-vim/fugitive"
diff --git a/app-vim/gitv/gitv-1.3.ebuild b/app-vim/gitv/gitv-1.3.ebuild
new file mode 100644
index 000000000000..87c0d378112c
--- /dev/null
+++ b/app-vim/gitv/gitv-1.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3574"
+SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86 ~ppc-macos"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="dev-vcs/git
+ app-vim/fugitive"
diff --git a/app-vim/gitv/gitv-9999.ebuild b/app-vim/gitv/gitv-9999.ebuild
new file mode 100644
index 000000000000..628fe91e4e97
--- /dev/null
+++ b/app-vim/gitv/gitv-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/gregsexton/gitv.git"
+else
+ SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/ http://www.gregsexton.org/portfolio/gitv/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="dev-vcs/git
+ app-vim/fugitive"
diff --git a/app-vim/gitv/metadata.xml b/app-vim/gitv/metadata.xml
new file mode 100644
index 000000000000..178aec9074a1
--- /dev/null
+++ b/app-vim/gitv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">gregsexton/gitv</remote-id>
+ </upstream>
+</pkgmetadata>