summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2022-05-03 20:20:54 +0300
committerSam James <sam@gentoo.org>2022-05-03 19:39:50 +0100
commit569515aaae02628db02e1ba7b81ada12ea2f6cd5 (patch)
tree601d4d58f710b42815c791f71e191cc373cefd64 /app-text/scdoc
parentprofiles: mask dev-libs/libxml2-2.9.14 (diff)
downloadgentoo-569515aaae02628db02e1ba7b81ada12ea2f6cd5.tar.gz
gentoo-569515aaae02628db02e1ba7b81ada12ea2f6cd5.tar.bz2
gentoo-569515aaae02628db02e1ba7b81ada12ea2f6cd5.zip
app-text/scdoc: fix incorrect prefix in pc file
* Removal of PREFIX in make all breaks sed'ing @prefix@ leading to default value of /usr/local to be used leading to breakage in packages that depend on the value being correct to find the scdoc binary. Closes: https://bugs.gentoo.org/842282 Closes: https://bugs.gentoo.org/842285 Closes: https://bugs.gentoo.org/842288 Closes: https://bugs.gentoo.org/842399 Closes: https://bugs.gentoo.org/842465 Closes: https://bugs.gentoo.org/842402 Closes: https://bugs.gentoo.org/842279 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/25301 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/scdoc')
-rw-r--r--app-text/scdoc/scdoc-1.11.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/scdoc/scdoc-1.11.2-r1.ebuild b/app-text/scdoc/scdoc-1.11.2-r1.ebuild
new file mode 100644
index 000000000000..c40dcd50d0fa
--- /dev/null
+++ b/app-text/scdoc/scdoc-1.11.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Standalone tool for generating man pages with a simple syntax"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/scdoc"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/scdoc"
+ inherit git-r3
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/scdoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ sed -e 's/-Werror//' \
+ -i Makefile || die 'Failed to patch Makefile'
+}
+
+src_compile() {
+ local MY_HS="./scdoc"
+ if tc-is-cross-compiler; then
+ tc-export_build_env
+ MY_HS="./hostscdoc"
+ emake scdoc HOST_SCDOC="./hostscdoc" OUTDIR="${S}/.build.host" CC="$(tc-getBUILD_CC)" \
+ CFLAGS="${BUILD_CFLAGS} -DVERSION='\"${PV}\"'" LDFLAGS="${BUILD_LDFLAGS}"
+ mv scdoc hostscdoc || die 'Failed to rename host scdoc'
+ fi
+
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}" \
+ PCDIR="/usr/$(get_libdir)/pkgconfig" install
+}