summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-12-23 22:30:33 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-23 22:51:18 +0100
commit51b98c132c5f8752705469d54fcd38a5ed21d407 (patch)
treedd5b5d3f01ac6a5cfe154ccb46f3fa5e83e8cd18 /app-text/aspell
parentsys-auth/AusweisApp2: add 2.0.1 (diff)
downloadgentoo-51b98c132c5f8752705469d54fcd38a5ed21d407.tar.gz
gentoo-51b98c132c5f8752705469d54fcd38a5ed21d407.tar.bz2
gentoo-51b98c132c5f8752705469d54fcd38a5ed21d407.zip
app-text/aspell: add 0.60.8.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/Manifest1
-rw-r--r--app-text/aspell/aspell-0.60.8.1.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index 6fa52b539146..3afb8f37a033 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1 +1,2 @@
+DIST aspell-0.60.8.1.tar.gz 3567205 BLAKE2B b7e2045658d9553beef9a7fb69264fdd5be22b5b8abce93baf08111ca5bb3e0bfedb9f351d0e4cde9d41e20960b584d8f02c0df02268cf282c925edc8ffbab8d SHA512 80fa9d7f5f4b8bf66388825ae28403713a2e3eda81fc31f2f452c3e2fe8349cd0fa8f0e4d0d3f8cffe215817229af25aa7be2dba358cb9cdc97e9d2834ba5ca7
DIST aspell-0.60.8.tar.gz 3486448 BLAKE2B a72e70af65749059a576740377f93b20ab283f73fa7919894f6af189b5aa73581fa0410800851c9396e7d13f4cbc2f7edc23c53d46874d0389ffdb2432ff08c2 SHA512 8ef4952c553b6234dfe777240d2d97beb13ef9201e18d56bee3b5068d13525db3625b7130d9f5122f7c529da0ccb0c70eb852a81472a7d15fb7c4ee5ba21cd29
diff --git a/app-text/aspell/aspell-0.60.8.1.ebuild b/app-text/aspell/aspell-0.60.8.1.ebuild
new file mode 100644
index 000000000000..57fd9b0641e0
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.8.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic libtool
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Free and Open Source spell checker designed to replace Ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="mirror://gnu/aspell/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="nls unicode"
+
+# All available language app-dicts/aspell-* packages.
+LANGUAGES=( af am ar ast az be bg bn br ca cs csb cy da de de-1901 el en eo es et fa
+ fi fo fr fy ga gd gl grc gu gv he hi hil hr hsb hu hus hy ia id is it kn ku
+ ky la lt lv mg mi mk ml mn mr ms mt nb nds nl nn no ny or pa pl pt-PT pt-BR
+ qu ro ru rw sc sk sl sr sv sw ta te tet tk tl tn tr uk uz vi wa yi zu
+)
+
+for LANG in ${LANGUAGES[@]}; do
+ IUSE+=" l10n_${LANG}"
+
+ case ${LANG} in
+ de-1901)
+ DICT="de-alt"
+ ;;
+ pt-BR)
+ DICT="pt-br"
+ ;;
+ pt-PT)
+ DICT="pt"
+ ;;
+ *)
+ DICT="${LANG}"
+ ;;
+ esac
+
+ PDEPEND+=" l10n_${LANG}? ( app-dicts/aspell-${DICT} )"
+done
+unset DICT LANG LANGUAGES
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode(+)?]
+ nls? ( virtual/libintl )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+HTML_DOCS=( manual/aspell{,-dev}.html )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.60.5-nls.patch"
+ "${FILESDIR}/${PN}-0.60.5-solaris.patch"
+ "${FILESDIR}/${PN}-0.60.6-darwin-bundles.patch"
+ "${FILESDIR}/${PN}-0.60.6.1-clang.patch"
+ "${FILESDIR}/${PN}-0.60.6.1-unicode.patch"
+)
+
+src_prepare() {
+ default
+
+ rm m4/lt* m4/libtool.m4 || die
+ eautoreconf
+ elibtoolize --reverse-deps
+
+ # Parallel install of libtool libraries doesn't always work.
+ # https://lists.gnu.org/archive/html/libtool/2011-03/msg00003.html
+ # This has to be after automake has run so that we don't clobber
+ # the default target that automake creates for us.
+ echo 'install-filterLTLIBRARIES: install-libLTLIBRARIES' >> Makefile.in || die
+
+ # The unicode patch breaks on Darwin as NCURSES_WIDECHAR won't get set any more.
+ [[ ${CHOST} == *-darwin* ]] || [[ ${CHOST} == *-musl* ]] && use unicode && append-cppflags -DNCURSES_WIDECHAR=1
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable nls)
+ $(use_enable unicode)
+ --sysconfdir="${EPREFIX}"/etc/aspell
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc "${S}"/examples/*.c
+
+ # Install Aspell/Ispell compatibility scripts.
+ newbin scripts/ispell ispell-aspell
+ newbin scripts/spell spell-aspell
+
+ # As static build has been disabled,
+ # all .la files can be deleted unconditionally.
+ find "${ED}" -type f -name '*.la' -delete || die
+}