summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2022-05-19 10:06:17 -0400
committerRichard Freeman <rich0@gentoo.org>2022-05-19 10:06:17 -0400
commita5265b66029971168427eba7cce7996d9ea8e7a7 (patch)
tree98befc242edfe11639bfdbbb8763142b64e44730 /app-backup/duplicity
parentnet-libs/nodejs: arm stable wrt bug #841722 (diff)
downloadgentoo-a5265b66029971168427eba7cce7996d9ea8e7a7.tar.gz
gentoo-a5265b66029971168427eba7cce7996d9ea8e7a7.tar.bz2
gentoo-a5265b66029971168427eba7cce7996d9ea8e7a7.zip
app-backup/duplicity: add 0.8.23
Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.8.23.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.23-fix-docs-cmd.patch20
3 files changed, 72 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 2b5e31fc003d..479ad1bdd4c1 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,2 +1,3 @@
DIST duplicity-0.8.21.tar.gz 1375469 BLAKE2B 15da671b30305415dfafdef50f5f57eaea0d6504a3f35845bf4570bb0cd2d6d3c879e94dda5739f30acd54748ef7abb993405660d24cf96ab919cec08690e015 SHA512 573c79937e4b19e99d167fddaebfd7b747d3c5f240b14e575fecd45a225c6c279d5ce0132645bbefcddcbc688f9d67317a3ec3a0816fcb4ff303b217fe10b012
DIST duplicity-0.8.22.tar.gz 1408482 BLAKE2B 3a8b6eb79d5f67e8f274bdaaaf0bb5b6c9f0ebf91a3b6a849b876cdf2c9af0f5435946150b5db6ab5e524cedc5b98b40c456b1de0fe8c6e33c024fe3c7d881fa SHA512 474237e3ca9876fb124baf9871f781b8347c85e76b7b4191d6993a76fb4728500091c74ed0943c6c22d69651c08094b6d155eca742d1711bebe676734c84d12a
+DIST duplicity-0.8.23.tar.gz 1385252 BLAKE2B 63042486e6e17d2d93af72f617990c879763d5921e230302f406b4f9e7c57a67284130f9f57849b9ffc8638614b55f0f8abdf6bb20201155b33b72bef952ec9f SHA512 083cf0060a8c7a8472c6ee4ffbb87e85edf0fcdaba95862a9f272cc03d8ab3d18b584a8d256473e6cfab9eed6f993382b846b692a8c0dd46fd3a2d8215e54e45
diff --git a/app-backup/duplicity/duplicity-0.8.23.ebuild b/app-backup/duplicity/duplicity-0.8.23.ebuild
new file mode 100644
index 000000000000..05713d415754
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.23.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_8 python3_9 python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://duplicity.gitlab.io/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.23-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-0.8.23-fix-docs-cmd.patch
new file mode 100644
index 000000000000..2497beb25e01
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.23-fix-docs-cmd.patch
@@ -0,0 +1,20 @@
+--- duplicity-0.8.23/setup.py 2022-03-19 15:08:36.755624771 -0400
++++ duplicity-0.8.23/setup.py 2022-03-19 15:09:38.332763172 -0400
+@@ -94,17 +94,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % Version,
+- [
+- u'CHANGELOG.md',
+- u'CONTRIBUTING.md',
+- u'COPYING',
+- u'README.md',
+- u'README-LOG.md',
+- u'README-REPO.md',
+- u'README-TESTING.md',
+- ],
+- ),
+ ]
+
+ if not os.environ.get(u'READTHEDOCS') == u'True':