summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-01-15 23:47:41 +0300
committerSam James <sam@gentoo.org>2023-01-20 01:21:40 +0000
commitb0eef8eee1cdd098c9550908515843c7d30f7e63 (patch)
treee5781c4b7874df71462d374e03d8bd42fa015a45 /app-arch
parentmedia-libs/libsdl2: fix build with slibtool + clang (diff)
downloadgentoo-b0eef8eee1cdd098c9550908515843c7d30f7e63.tar.gz
gentoo-b0eef8eee1cdd098c9550908515843c7d30f7e63.tar.bz2
gentoo-b0eef8eee1cdd098c9550908515843c7d30f7e63.zip
app-arch/upx: drop 4.0.0, 4.0.1
Remove vulnerable versions. Bug: https://bugs.gentoo.org/890616 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29126 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/upx/Manifest1
-rw-r--r--app-arch/upx/upx-4.0.0.ebuild23
-rw-r--r--app-arch/upx/upx-4.0.1.ebuild30
3 files changed, 0 insertions, 54 deletions
diff --git a/app-arch/upx/Manifest b/app-arch/upx/Manifest
index 5f0bac2f3b6b..05cc0c7a1149 100644
--- a/app-arch/upx/Manifest
+++ b/app-arch/upx/Manifest
@@ -1,2 +1 @@
-DIST upx-4.0.0-src.tar.xz 1159308 BLAKE2B d2626a63b626f9b4e913b822e699fa93b7080d322b19555d44d7cf4ce17b37f0d50ec1381d07d0e4f8827e8edcd29d525d497fa79acd18d520ac58e176fb2b72 SHA512 fe3e8c594e845a91338b1e11fe3cb6371430af40a567187d63835e27da8b2abf993a104b0693063f4db984234bada7b2bd16ad79e3ad90861a1f495d99de7de6
DIST upx-4.0.1-src.tar.xz 1154032 BLAKE2B 0da23cedf73506e06e5dcf19ab0d194d8e578188bb4d75e760fe3f7dc7f24a9d42ff4b75fd9514162f48ae7cfad347b5bd65789805071354a74129960807843b SHA512 f2e42c83fd4a0d273a20c8b0f0d1eb201edcd1f10c779d2a6e8ac0812741c3af0c887382e54894190ecc4c7002a910524b2ed79ae7a7b595b8392598ad2e1235
diff --git a/app-arch/upx/upx-4.0.0.ebuild b/app-arch/upx/upx-4.0.0.ebuild
deleted file mode 100644
index 04a011030c35..000000000000
--- a/app-arch/upx/upx-4.0.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
-HOMEPAGE="https://upx.github.io/"
-SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
-S="${WORKDIR}/${P}-src"
-
-LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="!app-arch/upx-bin"
-BDEPEND="app-arch/xz-utils[extra-filters]"
-
-src_test() {
- # Don't run tests in parallel, #878977
- cmake_src_test -j1
-}
diff --git a/app-arch/upx/upx-4.0.1.ebuild b/app-arch/upx/upx-4.0.1.ebuild
deleted file mode 100644
index 44d1747d853c..000000000000
--- a/app-arch/upx/upx-4.0.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
-HOMEPAGE="https://upx.github.io/"
-SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
-S="${WORKDIR}/${P}-src"
-
-LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc x86"
-
-RDEPEND="!app-arch/upx-bin"
-BDEPEND="app-arch/xz-utils[extra-filters]"
-
-src_configure() {
- local mycmakeargs=(
- -DUPX_CONFIG_DISABLE_WERROR=ON
- )
- cmake_src_configure
-}
-
-src_test() {
- # Don't run tests in parallel, #878977
- cmake_src_test -j1
-}