summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-14 16:28:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-14 17:23:03 +0100
commitc63dcee6b6de97a61b4516afbe0aeef4498f5120 (patch)
tree038154dc423e0c04ecb40dd4b4b1013b7a21c6d9
parentdev-python/setuptools: Bump to 67.3.1 (diff)
downloadgentoo-c63dcee6b6de97a61b4516afbe0aeef4498f5120.tar.gz
gentoo-c63dcee6b6de97a61b4516afbe0aeef4498f5120.tar.bz2
gentoo-c63dcee6b6de97a61b4516afbe0aeef4498f5120.zip
dev-python/starlette: Bump to 0.25.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.25.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index b9fb037d71b8..998ec3b9f949 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1,3 +1,4 @@
DIST starlette-0.21.0.gh.tar.gz 2830353 BLAKE2B 7ff818d4687757ec8699dcd0e2582af78211787b7a0f2110da045eb4f7a8760262cf144b0af7dc9f72140b5dae1e65f7a4207ee3b165db4091c5139ce0bfcc85 SHA512 c246862604ba807141313857321d898d996eaa771ccb197546d0928a75cbb69f0e485fe90d2c817e70323146077c487436516384e1401d815c59c0ac75845e2b
DIST starlette-0.23.1.gh.tar.gz 2830865 BLAKE2B b1eaf59421d413179ad294b240babb9b1beabbf10d8364187eb406a3b87a1412b3959b90f44ac1bbada7858c3ffc90560208bc433ca5aaf835dda1766282fe65 SHA512 9af4ab2b2e3af4e7acd2e93a9a4b4f4c8c3b56ba971f7a8faf65308d76a4f30b8ab0ab263535480af614a5082420cafb3d939c7477472710cce9241bd947139b
DIST starlette-0.24.0.gh.tar.gz 2834269 BLAKE2B 82e1ae2cd835015f20c5421254c0facbe16c1592d1f34e95d38c94898fb30e308dd32ab8bc1856c16d600074c86300afc4aa11e2617a94a29aad9dc4dd0fbdfc SHA512 6ff38cb48efd25183971ea4578dbbd7aff537d624fe2e2b9249551b9bf559dad05da949ec52d305bb0323e37c837212e3a804c7614884e5cd4b85260ec1435cc
+DIST starlette-0.25.0.gh.tar.gz 2835696 BLAKE2B 82ed915a2ff7824a99e0f15f16a0723b8799ef43ab5b25dbbf7ee7bff7a3a1fc555e802a82950b11eb752a39e23fdf0870090a99bed568bfa82e3ecbcf42f5f3 SHA512 ecff4905c093ffd21a4b102d4ca1dba22ceebd8e73f53f984fbe58daa7a0bf9c3de9a41b1672837602142a4e14787f3b59291d05b9cb6a0dd034d58ddacd9eb1
diff --git a/dev-python/starlette/starlette-0.25.0.ebuild b/dev-python/starlette/starlette-0.25.0.ebuild
new file mode 100644
index 000000000000..65f85b51857a
--- /dev/null
+++ b/dev-python/starlette/starlette-0.25.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest