aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/archspec/archspec-0.2.5.ebuild')
-rw-r--r--dev-python/archspec/archspec-0.2.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/archspec/archspec-0.2.5.ebuild b/dev-python/archspec/archspec-0.2.5.ebuild
new file mode 100644
index 000000000..002a57ba1
--- /dev/null
+++ b/dev-python/archspec/archspec-0.2.5.ebuild
@@ -0,0 +1,21 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1 pypi
+
+DESCRIPTION="Labels for various aspects of a system architecture like CPU, etc."
+HOMEPAGE="https://archspec.readthedocs.io/en/latest/index.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest