diff options
author | 2009-08-28 15:27:29 -0300 | |
---|---|---|
committer | 2009-09-04 09:37:33 -0500 | |
commit | 33837ba6c5aa53c4ae4c0d2ffc66475b92d0da46 (patch) | |
tree | 5fdedad5f55cf86b11641ad6ba04dcdd55a3a27a /Makefile | |
parent | Add check support (diff) | |
download | qemu-kvm-33837ba6c5aa53c4ae4c0d2ffc66475b92d0da46.tar.gz qemu-kvm-33837ba6c5aa53c4ae4c0d2ffc66475b92d0da46.tar.bz2 qemu-kvm-33837ba6c5aa53c4ae4c0d2ffc66475b92d0da46.zip |
Introduce QInt unit-tests
This suite contains tests to assure that QInt API works as expected.
To execute it you should have check installed and build QEMU with
check support enabled (--enable-check-utests) and then run:
$ ./check-qint
Signed-off-by: Luiz Capitulino <lcapitulino@redhat.com>
Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -181,6 +181,8 @@ qemu-io$(EXESUF): qemu-io.o qemu-tool.o cmd.o $(block-obj-y) qemu-img-cmds.h: $(SRC_PATH)/qemu-img-cmds.hx $(call quiet-command,sh $(SRC_PATH)/hxtool -h < $< > $@," GEN $@") +check-qint: check-qint.o qint.o qemu-malloc.o + clean: # avoid old build problems by removing potentially incorrect old files rm -f config.mak config.h op-i386.h opc-i386.h gen-op-i386.h op-arm.h opc-arm.h gen-op-arm.h |