summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2010-01-16 21:52:41 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2010-05-16 16:55:40 +0000
commita9c3aa244648330a585e15818ec808a7d665d0f3 (patch)
treeb0e4d25e74718f67d04e2981712e74ec1ed4e803 /02040_all_embedded-library-shared-5.1.39.patch
parentA few more updates to build libmysqld as a shared lib. (diff)
downloadmysql-extras-a9c3aa244648330a585e15818ec808a7d665d0f3.tar.gz
mysql-extras-a9c3aa244648330a585e15818ec808a7d665d0f3.tar.bz2
mysql-extras-a9c3aa244648330a585e15818ec808a7d665d0f3.zip
Let's try building yassl without libtool.
Diffstat (limited to '02040_all_embedded-library-shared-5.1.39.patch')
-rw-r--r--02040_all_embedded-library-shared-5.1.39.patch131
1 files changed, 61 insertions, 70 deletions
diff --git a/02040_all_embedded-library-shared-5.1.39.patch b/02040_all_embedded-library-shared-5.1.39.patch
index 2484e91..7229e9d 100644
--- a/02040_all_embedded-library-shared-5.1.39.patch
+++ b/02040_all_embedded-library-shared-5.1.39.patch
@@ -1,6 +1,6 @@
diff -urN mysql-orig/client/Makefile.am mysql/client/Makefile.am
---- mysql-orig/client/Makefile.am 2010-01-16 21:25:12.799725815 -0100
-+++ mysql/client/Makefile.am 2010-01-16 21:27:15.764765863 -0100
+--- mysql-orig/client/Makefile.am 2010-01-16 21:48:35.558476827 -0100
++++ mysql/client/Makefile.am 2010-01-16 21:48:46.030349735 -0100
@@ -75,7 +75,7 @@
mysqlimport_LDADD = $(CXXLDFLAGS) $(CLIENT_THREAD_LIBS) \
@CLIENT_EXTRA_LDFLAGS@ \
@@ -30,8 +30,8 @@ diff -urN mysql-orig/client/Makefile.am mysql/client/Makefile.am
mysql_upgrade_SOURCES= mysql_upgrade.c \
diff -urN mysql-orig/configure.in mysql/configure.in
---- mysql-orig/configure.in 2010-01-16 21:25:12.838727584 -0100
-+++ mysql/configure.in 2010-01-16 21:25:26.061599582 -0100
+--- mysql-orig/configure.in 2010-01-16 21:48:35.597476763 -0100
++++ mysql/configure.in 2010-01-16 21:48:46.031350282 -0100
@@ -227,7 +227,7 @@
fi
@@ -71,8 +71,8 @@ diff -urN mysql-orig/configure.in mysql/configure.in
sql_server="vio sql"
fi
diff -urN mysql-orig/dbug/Makefile.am mysql/dbug/Makefile.am
---- mysql-orig/dbug/Makefile.am 2010-01-16 21:25:12.805724931 -0100
-+++ mysql/dbug/Makefile.am 2010-01-16 21:25:26.062599244 -0100
+--- mysql-orig/dbug/Makefile.am 2010-01-16 21:48:35.564474473 -0100
++++ mysql/dbug/Makefile.am 2010-01-16 21:48:46.032350805 -0100
@@ -16,10 +16,10 @@
# MA 02111-1307, USA
@@ -102,8 +102,8 @@ diff -urN mysql-orig/dbug/Makefile.am mysql/dbug/Makefile.am
user.t: user.r $(NROFF_INC)
-nroff -mm user.r > $@
diff -urN mysql-orig/extra/Makefile.am mysql/extra/Makefile.am
---- mysql-orig/extra/Makefile.am 2010-01-16 21:25:12.805724931 -0100
-+++ mysql/extra/Makefile.am 2010-01-16 21:25:26.062599244 -0100
+--- mysql-orig/extra/Makefile.am 2010-01-16 21:48:35.564474473 -0100
++++ mysql/extra/Makefile.am 2010-01-16 21:48:46.033348817 -0100
@@ -15,8 +15,8 @@
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
@@ -116,8 +116,8 @@ diff -urN mysql-orig/extra/Makefile.am mysql/extra/Makefile.am
BUILT_SOURCES= $(top_builddir)/include/mysqld_error.h \
$(top_builddir)/include/sql_state.h \
diff -urN mysql-orig/libmysqld/Makefile.am mysql/libmysqld/Makefile.am
---- mysql-orig/libmysqld/Makefile.am 2010-01-16 21:25:12.715724706 -0100
-+++ mysql/libmysqld/Makefile.am 2010-01-16 21:25:26.063599695 -0100
+--- mysql-orig/libmysqld/Makefile.am 2010-01-16 21:48:35.473475210 -0100
++++ mysql/libmysqld/Makefile.am 2010-01-16 21:51:46.151349359 -0100
@@ -36,8 +36,8 @@
$(openssl_includes) @ZLIB_INCLUDES@ \
@condition_dependent_plugin_includes@
@@ -142,7 +142,7 @@ diff -urN mysql-orig/libmysqld/Makefile.am mysql/libmysqld/Makefile.am
sqlstoragesources = $(EXTRA_libmysqld_a_SOURCES)
storagesources = @condition_dependent_plugin_modules@
-@@ -90,19 +90,19 @@
+@@ -90,12 +90,12 @@
# automake misses these
sql_yacc.cc sql_yacc.h: $(top_srcdir)/sql/sql_yacc.yy
@@ -161,15 +161,6 @@ diff -urN mysql-orig/libmysqld/Makefile.am mysql/libmysqld/Makefile.am
@NDB_SCI_LIBS@ \
@mysql_plugin_libs@ \
$(yassl_inc_libs)
-
- if HAVE_YASSL
--yassl_inc_libs= $(top_builddir)/extra/yassl/src/.libs/libyassl.a \
-- $(top_builddir)/extra/yassl/taocrypt/src/.libs/libtaocrypt.a
-+yassl_inc_libs= $(top_builddir)/extra/yassl/src/.libs/libyassl.la \
-+ $(top_builddir)/extra/yassl/taocrypt/src/.libs/libtaocrypt.la
- endif
-
- # Storage engine specific compilation options
@@ -140,7 +140,7 @@
#
@@ -189,8 +180,8 @@ diff -urN mysql-orig/libmysqld/Makefile.am mysql/libmysqld/Makefile.am
mwld -lib -o $@ libmysqld_int.a `echo $(INC_LIB) | sort -u` $(storageobjects)
else
diff -urN mysql-orig/mysys/Makefile.am mysql/mysys/Makefile.am
---- mysql-orig/mysys/Makefile.am 2010-01-16 21:25:12.808475868 -0100
-+++ mysql/mysys/Makefile.am 2010-01-16 21:25:26.064476605 -0100
+--- mysql-orig/mysys/Makefile.am 2010-01-16 21:48:35.567474887 -0100
++++ mysql/mysys/Makefile.am 2010-01-16 21:48:46.034349566 -0100
@@ -18,10 +18,9 @@
MYSQLBASEdir= $(prefix)
INCLUDES = @ZLIB_INCLUDES@ -I$(top_builddir)/include \
@@ -298,8 +289,8 @@ diff -urN mysql-orig/mysys/Makefile.am mysql/mysys/Makefile.am
$(LINK) $(FLAGS) -DMAIN ./test_base64.c $(LDADD) $(LIBS)
$(RM) -f ./test_base64.c
diff -urN mysql-orig/netware/BUILD/compile-linux-tools mysql/netware/BUILD/compile-linux-tools
---- mysql-orig/netware/BUILD/compile-linux-tools 2010-01-16 21:25:12.716724575 -0100
-+++ mysql/netware/BUILD/compile-linux-tools 2010-01-16 21:25:26.064476605 -0100
+--- mysql-orig/netware/BUILD/compile-linux-tools 2010-01-16 21:48:35.475474895 -0100
++++ mysql/netware/BUILD/compile-linux-tools 2010-01-16 21:48:46.034349566 -0100
@@ -34,14 +34,14 @@
# Create mysql_version.h which was deleted my previous step
./config.status include/mysql_version.h
@@ -324,8 +315,8 @@ diff -urN mysql-orig/netware/BUILD/compile-linux-tools mysql/netware/BUILD/compi
(cd libmysql; make conf_to_src)
(cd libmysql_r; make conf_to_src)
diff -urN mysql-orig/netware/Makefile.am mysql/netware/Makefile.am
---- mysql-orig/netware/Makefile.am 2010-01-16 21:25:12.716724575 -0100
-+++ mysql/netware/Makefile.am 2010-01-16 21:25:26.064476605 -0100
+--- mysql-orig/netware/Makefile.am 2010-01-16 21:48:35.474353744 -0100
++++ mysql/netware/Makefile.am 2010-01-16 21:48:46.035349642 -0100
@@ -16,14 +16,14 @@
if HAVE_NETWARE
@@ -345,8 +336,8 @@ diff -urN mysql-orig/netware/Makefile.am mysql/netware/Makefile.am
netware_build_files = client/mysql.def client/mysqladmin.def \
diff -urN mysql-orig/regex/Makefile.am mysql/regex/Makefile.am
---- mysql-orig/regex/Makefile.am 2010-01-16 21:25:12.800725060 -0100
-+++ mysql/regex/Makefile.am 2010-01-16 21:25:26.065599179 -0100
+--- mysql-orig/regex/Makefile.am 2010-01-16 21:48:35.559475967 -0100
++++ mysql/regex/Makefile.am 2010-01-16 21:48:46.035349642 -0100
@@ -16,10 +16,10 @@
# MA 02111-1307, USA
@@ -362,8 +353,8 @@ diff -urN mysql-orig/regex/Makefile.am mysql/regex/Makefile.am
re_SOURCES = split.c debug.c main.c
re_LDFLAGS= @NOINST_LDFLAGS@
diff -urN mysql-orig/server-tools/instance-manager/Makefile.am mysql/server-tools/instance-manager/Makefile.am
---- mysql-orig/server-tools/instance-manager/Makefile.am 2010-01-16 21:25:12.582599147 -0100
-+++ mysql/server-tools/instance-manager/Makefile.am 2010-01-16 21:25:26.065599179 -0100
+--- mysql-orig/server-tools/instance-manager/Makefile.am 2010-01-16 21:48:35.340350827 -0100
++++ mysql/server-tools/instance-manager/Makefile.am 2010-01-16 21:48:46.035349642 -0100
@@ -87,10 +87,10 @@
mysqlmanager_LDADD= @CLIENT_EXTRA_LDFLAGS@ \
liboptions.la \
@@ -380,8 +371,8 @@ diff -urN mysql-orig/server-tools/instance-manager/Makefile.am mysql/server-tool
EXTRA_DIST = WindowsService.cpp WindowsService.h IMService.cpp \
diff -urN mysql-orig/sql/Makefile.am mysql/sql/Makefile.am
---- mysql-orig/sql/Makefile.am 2010-01-16 21:25:12.735352503 -0100
-+++ mysql/sql/Makefile.am 2010-01-16 21:25:26.066599600 -0100
+--- mysql-orig/sql/Makefile.am 2010-01-16 21:48:35.493477106 -0100
++++ mysql/sql/Makefile.am 2010-01-16 21:48:46.036350186 -0100
@@ -32,11 +32,11 @@
noinst_LTLIBRARIES= libndb.la \
udf_example.la
@@ -400,8 +391,8 @@ diff -urN mysql-orig/sql/Makefile.am mysql/sql/Makefile.am
LDADD = $(SUPPORTING_LIBS) @ZLIB_LIBS@ @NDB_SCI_LIBS@
mysqld_LDADD = libndb.la \
diff -urN mysql-orig/storage/archive/Makefile.am mysql/storage/archive/Makefile.am
---- mysql-orig/storage/archive/Makefile.am 2010-01-16 21:25:12.797724682 -0100
-+++ mysql/storage/archive/Makefile.am 2010-01-16 21:25:26.066599600 -0100
+--- mysql-orig/storage/archive/Makefile.am 2010-01-16 21:48:35.556418316 -0100
++++ mysql/storage/archive/Makefile.am 2010-01-16 21:48:46.036350186 -0100
@@ -50,17 +50,17 @@
archive_test_SOURCES = archive_test.c azio.c
@@ -427,8 +418,8 @@ diff -urN mysql-orig/storage/archive/Makefile.am mysql/storage/archive/Makefile.
archive_reader_LDFLAGS = @NOINST_LDFLAGS@
diff -urN mysql-orig/storage/heap/Makefile.am mysql/storage/heap/Makefile.am
---- mysql-orig/storage/heap/Makefile.am 2010-01-16 21:25:12.796724662 -0100
-+++ mysql/storage/heap/Makefile.am 2010-01-16 21:25:26.067599391 -0100
+--- mysql-orig/storage/heap/Makefile.am 2010-01-16 21:48:35.555475098 -0100
++++ mysql/storage/heap/Makefile.am 2010-01-16 21:48:46.037350910 -0100
@@ -26,21 +26,20 @@
LDADD =
@@ -461,8 +452,8 @@ diff -urN mysql-orig/storage/heap/Makefile.am mysql/storage/heap/Makefile.am
hp_rsame.c hp_create.c hp_rename.c hp_rfirst.c \
hp_rnext.c hp_rlast.c hp_rprev.c hp_clear.c \
diff -urN mysql-orig/storage/myisam/Makefile.am mysql/storage/myisam/Makefile.am
---- mysql-orig/storage/myisam/Makefile.am 2010-01-16 21:25:12.772725532 -0100
-+++ mysql/storage/myisam/Makefile.am 2010-01-16 21:25:26.067599391 -0100
+--- mysql-orig/storage/myisam/Makefile.am 2010-01-16 21:48:35.531349321 -0100
++++ mysql/storage/myisam/Makefile.am 2010-01-16 21:48:46.037350910 -0100
@@ -30,60 +30,60 @@
EXTRA_DIST = mi_test_all.sh mi_test_all.res ft_stem.c CMakeLists.txt plug.in
pkgdata_DATA = mi_test_all mi_test_all.res
@@ -574,8 +565,8 @@ diff -urN mysql-orig/storage/myisam/Makefile.am mysql/storage/myisam/Makefile.am
mi_search.c mi_page.c mi_key.c mi_locking.c \
mi_rrnd.c mi_scan.c mi_cache.c \
diff -urN mysql-orig/storage/ndb/src/common/util/Makefile.am mysql/storage/ndb/src/common/util/Makefile.am
---- mysql-orig/storage/ndb/src/common/util/Makefile.am 2010-01-16 21:25:12.766724385 -0100
-+++ mysql/storage/ndb/src/common/util/Makefile.am 2010-01-16 21:39:49.389754505 -0100
+--- mysql-orig/storage/ndb/src/common/util/Makefile.am 2010-01-16 21:48:35.525474467 -0100
++++ mysql/storage/ndb/src/common/util/Makefile.am 2010-01-16 21:48:46.038349555 -0100
@@ -31,9 +31,9 @@
testBitmask_SOURCES = testBitmask.cpp
testBitmask_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -590,8 +581,8 @@ diff -urN mysql-orig/storage/ndb/src/common/util/Makefile.am mysql/storage/ndb/s
testBitmask.cpp : Bitmask.cpp
rm -f testBitmask.cpp
diff -urN mysql-orig/storage/ndb/src/cw/cpcd/Makefile.am mysql/storage/ndb/src/cw/cpcd/Makefile.am
---- mysql-orig/storage/ndb/src/cw/cpcd/Makefile.am 2010-01-16 21:25:12.751724944 -0100
-+++ mysql/storage/ndb/src/cw/cpcd/Makefile.am 2010-01-16 21:30:58.936348890 -0100
+--- mysql-orig/storage/ndb/src/cw/cpcd/Makefile.am 2010-01-16 21:48:35.510475095 -0100
++++ mysql/storage/ndb/src/cw/cpcd/Makefile.am 2010-01-16 21:48:46.038349555 -0100
@@ -19,9 +19,9 @@
LDADD_LOC = \
@@ -606,8 +597,8 @@ diff -urN mysql-orig/storage/ndb/src/cw/cpcd/Makefile.am mysql/storage/ndb/src/c
include $(top_srcdir)/storage/ndb/config/common.mk.am
include $(top_srcdir)/storage/ndb/config/type_util.mk.am
diff -urN mysql-orig/storage/ndb/src/kernel/blocks/backup/Makefile.am mysql/storage/ndb/src/kernel/blocks/backup/Makefile.am
---- mysql-orig/storage/ndb/src/kernel/blocks/backup/Makefile.am 2010-01-16 21:25:12.762726799 -0100
-+++ mysql/storage/ndb/src/kernel/blocks/backup/Makefile.am 2010-01-16 21:37:46.487350311 -0100
+--- mysql-orig/storage/ndb/src/kernel/blocks/backup/Makefile.am 2010-01-16 21:48:35.521350993 -0100
++++ mysql/storage/ndb/src/kernel/blocks/backup/Makefile.am 2010-01-16 21:48:46.039349310 -0100
@@ -17,9 +17,9 @@
ndb_print_backup_file_SOURCES = read.cpp
ndb_print_backup_file_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -622,8 +613,8 @@ diff -urN mysql-orig/storage/ndb/src/kernel/blocks/backup/Makefile.am mysql/stor
include $(top_srcdir)/storage/ndb/config/common.mk.am
include $(top_srcdir)/storage/ndb/config/type_kernel.mk.am
diff -urN mysql-orig/storage/ndb/src/kernel/blocks/dbdict/Makefile.am mysql/storage/ndb/src/kernel/blocks/dbdict/Makefile.am
---- mysql-orig/storage/ndb/src/kernel/blocks/dbdict/Makefile.am 2010-01-16 21:25:12.761725325 -0100
-+++ mysql/storage/ndb/src/kernel/blocks/dbdict/Makefile.am 2010-01-16 21:37:26.670383037 -0100
+--- mysql-orig/storage/ndb/src/kernel/blocks/dbdict/Makefile.am 2010-01-16 21:48:35.519476594 -0100
++++ mysql/storage/ndb/src/kernel/blocks/dbdict/Makefile.am 2010-01-16 21:48:46.039349310 -0100
@@ -19,17 +19,17 @@
LDADD += \
$(top_builddir)/storage/ndb/src/common/util/libgeneral.la \
@@ -649,8 +640,8 @@ diff -urN mysql-orig/storage/ndb/src/kernel/blocks/dbdict/Makefile.am mysql/stor
# Don't update the files from bitkeeper
%::SCCS/s.%
diff -urN mysql-orig/storage/ndb/src/kernel/blocks/dbdih/Makefile.am mysql/storage/ndb/src/kernel/blocks/dbdih/Makefile.am
---- mysql-orig/storage/ndb/src/kernel/blocks/dbdih/Makefile.am 2010-01-16 21:25:12.760726578 -0100
-+++ mysql/storage/ndb/src/kernel/blocks/dbdih/Makefile.am 2010-01-16 21:36:35.559349861 -0100
+--- mysql-orig/storage/ndb/src/kernel/blocks/dbdih/Makefile.am 2010-01-16 21:48:35.518476431 -0100
++++ mysql/storage/ndb/src/kernel/blocks/dbdih/Makefile.am 2010-01-16 21:48:46.039349310 -0100
@@ -17,9 +17,9 @@
ndb_print_sys_file_SOURCES = printSysfile.cpp
ndb_print_sys_file_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -665,8 +656,8 @@ diff -urN mysql-orig/storage/ndb/src/kernel/blocks/dbdih/Makefile.am mysql/stora
include $(top_srcdir)/storage/ndb/config/common.mk.am
diff -urN mysql-orig/storage/ndb/src/kernel/blocks/dblqh/Makefile.am mysql/storage/ndb/src/kernel/blocks/dblqh/Makefile.am
---- mysql-orig/storage/ndb/src/kernel/blocks/dblqh/Makefile.am 2010-01-16 21:25:12.759725662 -0100
-+++ mysql/storage/ndb/src/kernel/blocks/dblqh/Makefile.am 2010-01-16 21:35:47.669449780 -0100
+--- mysql-orig/storage/ndb/src/kernel/blocks/dblqh/Makefile.am 2010-01-16 21:48:35.517475619 -0100
++++ mysql/storage/ndb/src/kernel/blocks/dblqh/Makefile.am 2010-01-16 21:48:46.040349461 -0100
@@ -23,9 +23,9 @@
ndbd_redo_log_reader_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -681,8 +672,8 @@ diff -urN mysql-orig/storage/ndb/src/kernel/blocks/dblqh/Makefile.am mysql/stora
# Don't update the files from bitkeeper
%::SCCS/s.%
diff -urN mysql-orig/storage/ndb/src/kernel/blocks/dbtup/Makefile.am mysql/storage/ndb/src/kernel/blocks/dbtup/Makefile.am
---- mysql-orig/storage/ndb/src/kernel/blocks/dbtup/Makefile.am 2010-01-16 21:25:12.757724432 -0100
-+++ mysql/storage/ndb/src/kernel/blocks/dbtup/Makefile.am 2010-01-16 21:35:10.035931442 -0100
+--- mysql-orig/storage/ndb/src/kernel/blocks/dbtup/Makefile.am 2010-01-16 21:48:35.516424754 -0100
++++ mysql/storage/ndb/src/kernel/blocks/dbtup/Makefile.am 2010-01-16 21:48:46.040349461 -0100
@@ -20,9 +20,9 @@
test_varpage_SOURCES = test_varpage.cpp tuppage.cpp
test_varpage_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -697,8 +688,8 @@ diff -urN mysql-orig/storage/ndb/src/kernel/blocks/dbtup/Makefile.am mysql/stora
# Don't update the files from bitkeeper
%::SCCS/s.%
diff -urN mysql-orig/storage/ndb/src/kernel/blocks/Makefile.am mysql/storage/ndb/src/kernel/blocks/Makefile.am
---- mysql-orig/storage/ndb/src/kernel/blocks/Makefile.am 2010-01-16 21:25:12.755476743 -0100
-+++ mysql/storage/ndb/src/kernel/blocks/Makefile.am 2010-01-16 21:34:39.633876676 -0100
+--- mysql-orig/storage/ndb/src/kernel/blocks/Makefile.am 2010-01-16 21:48:35.514475610 -0100
++++ mysql/storage/ndb/src/kernel/blocks/Makefile.am 2010-01-16 21:48:46.041349682 -0100
@@ -57,9 +57,9 @@
ndb_print_file_SOURCES = print_file.cpp diskpage.cpp dbtup/tuppage.cpp
ndb_print_file_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -713,8 +704,8 @@ diff -urN mysql-orig/storage/ndb/src/kernel/blocks/Makefile.am mysql/storage/ndb
include $(top_srcdir)/storage/ndb/config/common.mk.am
include $(top_srcdir)/storage/ndb/config/type_kernel.mk.am
diff -urN mysql-orig/storage/ndb/src/kernel/Makefile.am mysql/storage/ndb/src/kernel/Makefile.am
---- mysql-orig/storage/ndb/src/kernel/Makefile.am 2010-01-16 21:25:12.764724308 -0100
-+++ mysql/storage/ndb/src/kernel/Makefile.am 2010-01-16 21:39:32.607349496 -0100
+--- mysql-orig/storage/ndb/src/kernel/Makefile.am 2010-01-16 21:48:35.523475086 -0100
++++ mysql/storage/ndb/src/kernel/Makefile.am 2010-01-16 21:48:46.041349682 -0100
@@ -53,9 +53,9 @@
$(top_builddir)/storage/ndb/src/mgmapi/libmgmapi.la \
$(top_builddir)/storage/ndb/src/common/portlib/libportlib.la \
@@ -729,8 +720,8 @@ diff -urN mysql-orig/storage/ndb/src/kernel/Makefile.am mysql/storage/ndb/src/ke
windoze-dsp: ndbd.dsp
diff -urN mysql-orig/storage/ndb/src/kernel/vm/Makefile.am mysql/storage/ndb/src/kernel/vm/Makefile.am
---- mysql-orig/storage/ndb/src/kernel/vm/Makefile.am 2010-01-16 21:25:12.764724308 -0100
-+++ mysql/storage/ndb/src/kernel/vm/Makefile.am 2010-01-16 21:39:05.895349538 -0100
+--- mysql-orig/storage/ndb/src/kernel/vm/Makefile.am 2010-01-16 21:48:35.522475553 -0100
++++ mysql/storage/ndb/src/kernel/vm/Makefile.am 2010-01-16 21:48:46.041349682 -0100
@@ -65,24 +65,24 @@
ndbd_malloc_impl_test_SOURCES = ndbd_malloc_impl.cpp
ndbd_malloc_impl_test_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -766,8 +757,8 @@ diff -urN mysql-orig/storage/ndb/src/kernel/vm/Makefile.am mysql/storage/ndb/src
+ $(top_builddir)/strings/libmystrings.la
diff -urN mysql-orig/storage/ndb/src/mgmclient/Makefile.am mysql/storage/ndb/src/mgmclient/Makefile.am
---- mysql-orig/storage/ndb/src/mgmclient/Makefile.am 2010-01-16 21:25:12.751724944 -0100
-+++ mysql/storage/ndb/src/mgmclient/Makefile.am 2010-01-16 21:31:59.097348810 -0100
+--- mysql-orig/storage/ndb/src/mgmclient/Makefile.am 2010-01-16 21:48:35.510475095 -0100
++++ mysql/storage/ndb/src/mgmclient/Makefile.am 2010-01-16 21:48:46.042349119 -0100
@@ -37,9 +37,9 @@
../common/portlib/libportlib.la \
@readline_link@ \
@@ -782,8 +773,8 @@ diff -urN mysql-orig/storage/ndb/src/mgmclient/Makefile.am mysql/storage/ndb/src
ndb_mgm_LDFLAGS = @ndb_bin_am_ldflags@
diff -urN mysql-orig/storage/ndb/src/mgmsrv/Makefile.am mysql/storage/ndb/src/mgmsrv/Makefile.am
---- mysql-orig/storage/ndb/src/mgmsrv/Makefile.am 2010-01-16 21:25:12.754725278 -0100
-+++ mysql/storage/ndb/src/mgmsrv/Makefile.am 2010-01-16 21:33:41.071473963 -0100
+--- mysql-orig/storage/ndb/src/mgmsrv/Makefile.am 2010-01-16 21:48:35.513474763 -0100
++++ mysql/storage/ndb/src/mgmsrv/Makefile.am 2010-01-16 21:48:46.043349411 -0100
@@ -40,9 +40,9 @@
LDADD_LOC = $(top_builddir)/storage/ndb/src/mgmclient/CommandInterpreter.lo \
@@ -798,8 +789,8 @@ diff -urN mysql-orig/storage/ndb/src/mgmsrv/Makefile.am mysql/storage/ndb/src/mg
@NDB_SCI_LIBS@ \
@TERMCAP_LIB@
diff -urN mysql-orig/storage/ndb/src/ndbapi/Makefile.am mysql/storage/ndb/src/ndbapi/Makefile.am
---- mysql-orig/storage/ndb/src/ndbapi/Makefile.am 2010-01-16 21:25:12.754725278 -0100
-+++ mysql/storage/ndb/src/ndbapi/Makefile.am 2010-01-16 21:32:41.960349260 -0100
+--- mysql-orig/storage/ndb/src/ndbapi/Makefile.am 2010-01-16 21:48:35.512475809 -0100
++++ mysql/storage/ndb/src/ndbapi/Makefile.am 2010-01-16 21:48:46.043349411 -0100
@@ -67,9 +67,9 @@
include $(top_srcdir)/storage/ndb/config/type_ndbapi.mk.am
@@ -814,8 +805,8 @@ diff -urN mysql-orig/storage/ndb/src/ndbapi/Makefile.am mysql/storage/ndb/src/nd
# Don't update the files from bitkeeper
%::SCCS/s.%
diff -urN mysql-orig/storage/ndb/test/run-test/Makefile.am mysql/storage/ndb/test/run-test/Makefile.am
---- mysql-orig/storage/ndb/test/run-test/Makefile.am 2010-01-16 21:25:12.745351003 -0100
-+++ mysql/storage/ndb/test/run-test/Makefile.am 2010-01-16 21:30:20.087348860 -0100
+--- mysql-orig/storage/ndb/test/run-test/Makefile.am 2010-01-16 21:48:35.504475775 -0100
++++ mysql/storage/ndb/test/run-test/Makefile.am 2010-01-16 21:48:46.043349411 -0100
@@ -34,9 +34,9 @@
INCLUDES_LOC = -I$(top_srcdir)/storage/ndb/test/include
LDADD_LOC = $(top_builddir)/storage/ndb/test/src/libNDBT.a \
@@ -830,8 +821,8 @@ diff -urN mysql-orig/storage/ndb/test/run-test/Makefile.am mysql/storage/ndb/tes
atrt_CXXFLAGS = -I$(top_srcdir)/ndb/src/mgmapi \
-I$(top_srcdir)/ndb/src/mgmsrv \
diff -urN mysql-orig/strings/Makefile.am mysql/strings/Makefile.am
---- mysql-orig/strings/Makefile.am 2010-01-16 21:25:12.814725854 -0100
-+++ mysql/strings/Makefile.am 2010-01-16 21:25:26.068599650 -0100
+--- mysql-orig/strings/Makefile.am 2010-01-16 21:48:35.573476307 -0100
++++ mysql/strings/Makefile.am 2010-01-16 21:48:46.044349817 -0100
@@ -16,7 +16,7 @@
# This file is public domain and comes with NO WARRANTY of any kind
@@ -889,8 +880,8 @@ diff -urN mysql-orig/strings/Makefile.am mysql/strings/Makefile.am
# Don't update the files from bitkeeper
diff -urN mysql-orig/unittest/mysys/Makefile.am mysql/unittest/mysys/Makefile.am
---- mysql-orig/unittest/mysys/Makefile.am 2010-01-16 21:25:12.797724682 -0100
-+++ mysql/unittest/mysys/Makefile.am 2010-01-16 21:25:26.068599650 -0100
+--- mysql-orig/unittest/mysys/Makefile.am 2010-01-16 21:48:35.556418316 -0100
++++ mysql/unittest/mysys/Makefile.am 2010-01-16 21:48:46.044349817 -0100
@@ -17,9 +17,9 @@
AM_CPPFLAGS += -I$(top_srcdir)/include -I$(top_srcdir)/unittest/mytap