aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Kletzander <mkletzan@redhat.com>2012-02-24 19:48:55 +0100
committerEric Blake <eblake@redhat.com>2012-02-24 16:49:21 -0700
commit9f748277bbd17d031f80d28e6d2fc4b52e8d5715 (patch)
treed01b242c29bb10c50a96918e55e7c70d0dc8d570 /src/driver.h
parentFixed service handling in specfile (diff)
downloadlibvirt-9f748277bbd17d031f80d28e6d2fc4b52e8d5715.tar.gz
libvirt-9f748277bbd17d031f80d28e6d2fc4b52e8d5715.tar.bz2
libvirt-9f748277bbd17d031f80d28e6d2fc4b52e8d5715.zip
Fixed URI parsing
Function xmlParseURI does not remove square brackets around IPv6 address when parsing. One of the solutions is making wrappers around functions working with xmlURI*. This assures that uri->server will be always properly assigned and it doesn't have to be changed when used on some new place in the code. For this purpose, functions virParseURI and virSaveURI were added. These function are wrappers around xmlParseURI and xmlSaveUri respectively. Also there is one new syntax check function to prohibit these functions anywhere else. File changes: - src/util/viruri.h -- declaration - src/util/viruri.c -- definition - src/libvirt_private.syms -- symbol export - src/Makefile.am -- added source and header files - cfg.mk -- added sc_prohibit_xmlURI - all others -- ID name and include fixes
Diffstat (limited to 'src/driver.h')
-rw-r--r--src/driver.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/driver.h b/src/driver.h
index d27fa99e8..b04b25464 100644
--- a/src/driver.h
+++ b/src/driver.h
@@ -9,9 +9,9 @@
# include "config.h"
# include <unistd.h>
-# include <libxml/uri.h>
# include "internal.h"
+# include "viruri.h"
/*
* List of registered drivers numbers
*/