aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-06-06 09:45:04 -0600
committerEric Blake <eblake@redhat.com>2012-06-06 14:49:27 -0600
commitca02b101d74510df424c5ea659d7b7d481874f98 (patch)
treeba07a2808b9b754307469db52146fa54bfaaf0f1 /src/Makefile.am
parentbuild: ensure storage driver is used (diff)
downloadlibvirt-ca02b101d74510df424c5ea659d7b7d481874f98.tar.gz
libvirt-ca02b101d74510df424c5ea659d7b7d481874f98.tar.bz2
libvirt-ca02b101d74510df424c5ea659d7b7d481874f98.zip
build: fix build of fresh checkout
Commit 7bff56a worked in an incremental build, but fails for a fresh clone; apparently, if make sees both an actual file spelling and an inference rule, only the exact spelling is used. CCLD libvirt_driver_test.la CC libvirt_driver_remote_la-remote_driver.lo remote/remote_driver.c:4707:34: fatal error: remote_client_bodies.h: No such file or directory compilation terminated. BUILT_SOURCES to the rescue, instead of trying to mess with .lo dependencies directly. * src/Makefile.am (REMOTE_DRIVER_PREREQS, %remote_driver.lo): Drop... (BUILT_SOURCES): ...and add here instead.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2d737afff..60f544279 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -654,8 +654,7 @@ libvirt_driver_remote_la_LIBADD = $(GNUTLS_LIBS) \
libvirt-net-rpc.la
libvirt_driver_remote_la_SOURCES = $(REMOTE_DRIVER_SOURCES)
-REMOTE_DRIVER_PREREQS = $(REMOTE_DRIVER_GENERATED)
-%remote_driver.lo: $(REMOTE_DRIVER_PREREQS)
+BUILT_SOURCES += $(REMOTE_DRIVER_GENERATED)
endif WITH_REMOTE
@@ -1297,7 +1296,7 @@ libvirt_la_BUILT_LIBADD += libvirt_probes.lo
libvirt_la_DEPENDENCIES += libvirt_probes.lo libvirt_probes.o
nodist_libvirt_la_SOURCES = libvirt_probes.h
if WITH_REMOTE
-REMOTE_DRIVER_PREREQS += libvirt_probes.h
+nodist_libvirt_driver_remote_la_SOURCES = libvirt_probes.h
endif WITH_REMOTE
BUILT_SOURCES += libvirt_probes.h libvirt_probes.stp libvirt_functions.stp