aboutsummaryrefslogtreecommitdiff
path: root/m4
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-11-29 16:42:23 -0700
committerEric Blake <eblake@redhat.com>2011-12-01 14:12:59 -0700
commit059d746ddb5000a24db7930a8cab789456f65995 (patch)
treee69991a369e3427ad17a42b5c6b6b7518d67c62a /m4
parentbuild: properly skip tests (diff)
downloadlibvirt-059d746ddb5000a24db7930a8cab789456f65995.tar.gz
libvirt-059d746ddb5000a24db7930a8cab789456f65995.tar.bz2
libvirt-059d746ddb5000a24db7930a8cab789456f65995.zip
build: update to latest gnulib
* .gnulib: Update to latest, for improved 'make syntax-check' and compiler warnings. * m4/virt-compile-warnings.m4 (LIBVIRT_COMPILE_WARNINGS): Re-silence -Wformat-nonliteral. * cfg.mk (_test_script_regex): Recognize our test scripts. * gnulib/local/lib/*.diff: Drop, now that gnulib has this. * tests/virsh-optparse: Fix use of compare. * tests/virsh-schedinfo: Likewise.
Diffstat (limited to 'm4')
-rw-r--r--m4/virt-compile-warnings.m48
1 files changed, 6 insertions, 2 deletions
diff --git a/m4/virt-compile-warnings.m4 b/m4/virt-compile-warnings.m4
index 305036fd0..213b3db70 100644
--- a/m4/virt-compile-warnings.m4
+++ b/m4/virt-compile-warnings.m4
@@ -55,8 +55,8 @@ AC_DEFUN([LIBVIRT_COMPILE_WARNINGS],[
# Things like virAsprintf mean we can't use this
dontwarn="$dontwarn -Wformat-nonliteral"
- # We might fundamentally need some of these disabled forever, but ideally
- # we'd turn many of them on
+ # We might fundamentally need some of these disabled forever, but
+ # ideally we'd turn many of them on
dontwarn="$dontwarn -Wfloat-equal"
dontwarn="$dontwarn -Wdeclaration-after-statement"
dontwarn="$dontwarn -Wcast-qual"
@@ -88,6 +88,10 @@ AC_DEFUN([LIBVIRT_COMPILE_WARNINGS],[
# that one off, so we need to manually enable this again
gl_WARN_ADD([-Wjump-misses-init])
+ # GNULIB turns on -Wformat=2 which implies -Wformat-nonliteral,
+ # so we need to manually re-exclude it.
+ gl_WARN_ADD([-Wno-format-nonliteral])
+
# This should be < 256 really. Currently we're down to 4096,
# but using 1024 bytes sized buffers (mostly for virStrerror)
# stops us from going down further