aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-08-21 00:29:49 -0600
committerEric Blake <eblake@redhat.com>2012-08-21 00:29:49 -0600
commitba9c38b430a71ed090e75f21d871fe4d5d51b958 (patch)
treed48c3513be5690857b6a61a1d6a098b2deb2f6b3 /configure.ac
parentvirsh: split out virsh-volume.c (diff)
downloadlibvirt-ba9c38b430a71ed090e75f21d871fe4d5d51b958.tar.gz
libvirt-ba9c38b430a71ed090e75f21d871fe4d5d51b958.tar.bz2
libvirt-ba9c38b430a71ed090e75f21d871fe4d5d51b958.zip
build: fix build with autoconf 2.59
Commit 350583c8 broke development on a RHEL 5 box, where the ancient Autoconf 2.59 lacks AS_VERSION_STRING. Rather than backport the complex awk script that newer autoconf uses for true strverscmp comparisons from the shell, it was easier to just open-code a shell case statement. * configure.ac (qemu_version): Open-code a replacement for AS_VERSION_CHECK.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ba5a3cd01..d65062642 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1121,8 +1121,11 @@ if test "$with_qemu:$with_yajl" = yes:check; then
else
[qemu_version_sed='s/.*ersion \([0-9.,]*\).*/\1/']
qemu_version=`$QEMU -version | sed "$qemu_version_sed"`
- AS_VERSION_COMPARE([$qemu_version], [0.15],
- [], [with_yajl=yes], [with_yajl=yes])
+ case $qemu_version in
+ [[1-9]].* | 0.15.* ) with_yajl=yes ;;
+ 0.* | '' ) ;;
+ *) AC_MSG_ERROR([Unexpected qemu version string]) ;;
+ esac
fi
fi
fi