aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-03-30 20:26:27 -0600
committerEric Blake <eblake@redhat.com>2011-03-30 20:26:27 -0600
commit6c9e89bbd2ff78fdbf0a6e7ba88d604b2da655c8 (patch)
tree5c85116deb05e83964a58ef67bf5a275656b4d8c /bootstrap.conf
parentdocs: mention C89 syntax preferences (diff)
downloadlibvirt-6c9e89bbd2ff78fdbf0a6e7ba88d604b2da655c8.tar.gz
libvirt-6c9e89bbd2ff78fdbf0a6e7ba88d604b2da655c8.tar.bz2
libvirt-6c9e89bbd2ff78fdbf0a6e7ba88d604b2da655c8.zip
maint: avoid locale-sensitivity in string case comparisons
strcase{cmp/str} have the drawback of being sensitive to the global locale; this is unacceptable in a library setting. Prefer a hard-coded C locale alternative for all but virsh, which is user facing and where the global locale isn't changing externally. * .gnulib: Update to latest, for c-strcasestr change. * bootstrap.conf (gnulib_modules): Drop strcasestr, add c-strcase and c-strcasestr. * cfg.mk (sc_avoid_strcase): New rule. (exclude_file_name_regexp--sc_avoid_strcase): New exception. * src/internal.h (STRCASEEQ, STRCASENEQ, STRCASEEQLEN) (STRCASENEQLEN): Adjust offenders. * src/qemu/qemu_monitor_text.c (qemuMonitorTextEjectMedia): Likewise. * tools/virsh.c (namesorter): Document exception.
Diffstat (limited to 'bootstrap.conf')
-rw-r--r--bootstrap.conf3
1 files changed, 2 insertions, 1 deletions
diff --git a/bootstrap.conf b/bootstrap.conf
index 6e1082881..733c3541c 100644
--- a/bootstrap.conf
+++ b/bootstrap.conf
@@ -22,6 +22,8 @@ gnulib_modules='
areadlink
base64
c-ctype
+c-strcase
+c-strcasestr
canonicalize-lgpl
chown
close
@@ -63,7 +65,6 @@ sigpipe
snprintf
socket
stpcpy
-strcasestr
strchrnul
strndup
strerror