aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-11-08 17:06:27 -0700
committerEric Blake <eblake@redhat.com>2011-11-09 09:03:33 -0700
commit676fdf8cb5d7a4d13d5bfc009e3c7958aa783072 (patch)
treed78f9eb92612b33f9ac2b2a5107f73e9c62acefc /bootstrap.conf
parentlxc: free error object to avoid memory leak (diff)
downloadlibvirt-676fdf8cb5d7a4d13d5bfc009e3c7958aa783072.tar.gz
libvirt-676fdf8cb5d7a4d13d5bfc009e3c7958aa783072.tar.bz2
libvirt-676fdf8cb5d7a4d13d5bfc009e3c7958aa783072.zip
build: allow for local gnulib diffs
Commit f7bd00c12 pulled in a gnulib module that fails to compile on mingw. While it would be nice to pull in a newer version of .gnulib that fixes this, it is difficult to backport any .gnulib update to older releases. So, it makes sense to take advantage of gnulib-tool's ability to support local diffs, where we can apply specific diffs in our use of gnulib without waiting for upstream gnulib to pick up those changes, as well as avoiding a wholesale .gnulib update. The existence of local diffs will also make it easier to backport fixes against a tarball (as long as a tarball and libvirt.git share the same .gnulib commit, then the tarball can be patched by applying the same local diffs as a post-release libvirt.git commit, without having to rerun an entire gnulib-tool bootstrap). This patch introduces the framework for supporting local diffs, without actually introducing any. * bootstrap.conf (local_gl_dir): New variable. * autogen.sh (bootstrap_hash): Hash any local diffs, to force a re-bootstrap if just diffs change. * cfg.mk (_update_required): Likewise.
Diffstat (limited to 'bootstrap.conf')
-rw-r--r--bootstrap.conf6
1 files changed, 4 insertions, 2 deletions
diff --git a/bootstrap.conf b/bootstrap.conf
index 4557d2da9..6498aba50 100644
--- a/bootstrap.conf
+++ b/bootstrap.conf
@@ -160,9 +160,10 @@ fi
# Tell gnulib to:
# require LGPLv2+
+# apply any local diffs in gnulib/local/ dir
# put *.m4 files in new gnulib/m4/ dir
-# put *.[ch] files in new gnulib/lib/ dir.
-# import gnulib tests in new gnulib/tests/ dir.
+# put *.[ch] files in new gnulib/lib/ dir
+# import gnulib tests in new gnulib/tests/ dir
gnulib_name=libgnu
m4_base=gnulib/m4
source_base=gnulib/lib
@@ -172,6 +173,7 @@ gnulib_tool_option_extras="\
--with-tests\
--avoid=pt_chown\
"
+local_gl_dir=gnulib/local
# Convince bootstrap to use multiple m4 directories.
: ${ACLOCAL=aclocal}