diff options
author | 2006-03-29 13:33:37 +0000 | |
---|---|---|
committer | 2006-03-29 13:33:37 +0000 | |
commit | 880f4e9ae20070c6c988b20730a7819b7b023d16 (patch) | |
tree | d0fba6b62fea2c9406c769102587217cf648c7f9 | |
parent | * include/libvirt.h[.in] include/virterror.h src/driver.h (diff) | |
download | libvirt-880f4e9ae20070c6c988b20730a7819b7b023d16.tar.gz libvirt-880f4e9ae20070c6c988b20730a7819b7b023d16.tar.bz2 libvirt-880f4e9ae20070c6c988b20730a7819b7b023d16.zip |
* python/libvir.c: fixed a bug in the new wrapper
* python/tests/Makefile.am python/tests/node.py: added a new test for
the new API
* python/tests/create.py: remove a debug
Daniel
-rw-r--r-- | ChangeLog | 7 | ||||
-rw-r--r-- | python/libvir.c | 4 | ||||
-rw-r--r-- | python/tests/Makefile.am | 3 | ||||
-rwxr-xr-x | python/tests/create.py | 3 | ||||
-rwxr-xr-x | python/tests/node.py | 34 |
5 files changed, 47 insertions, 4 deletions
@@ -1,3 +1,10 @@ +Wed Mar 29 13:34:25 EST 2006 Daniel Veillard <veillard@redhat.com> + + * python/libvir.c: fixed a bug in the new wrapper + * python/tests/Makefile.am python/tests/node.py: added a new test for + the new API + * python/tests/create.py: remove a debug + Wed Mar 29 14:43:56 CEST 2006 Daniel Veillard <veillard@redhat.com> * include/libvirt.h[.in] include/virterror.h src/driver.h diff --git a/python/libvir.c b/python/libvir.c index ede394956..786d47a60 100644 --- a/python/libvir.c +++ b/python/libvir.c @@ -215,8 +215,8 @@ libvirt_virNodeGetInfo(PyObject *self ATTRIBUTE_UNUSED, PyObject *args) { return(Py_None); } py_retval = PyList_New(8); - PyList_SetItem(py_retval, 0, libvirt_charPtrWrap(&info.model[0])); - PyList_SetItem(py_retval, 1, libvirt_longWrap((long) info.memory)); + PyList_SetItem(py_retval, 0, libvirt_constcharPtrWrap(&info.model[0])); + PyList_SetItem(py_retval, 1, libvirt_longWrap((long) info.memory >> 10)); PyList_SetItem(py_retval, 2, libvirt_intWrap((int) info.cpus)); PyList_SetItem(py_retval, 3, libvirt_intWrap((int) info.mhz)); PyList_SetItem(py_retval, 4, libvirt_intWrap((int) info.nodes)); diff --git a/python/tests/Makefile.am b/python/tests/Makefile.am index 586019078..dfa52e4f5 100644 --- a/python/tests/Makefile.am +++ b/python/tests/Makefile.am @@ -4,7 +4,8 @@ PYTESTS= \ basic.py \ create.py \ uuid.py \ - error.py + error.py \ + node.py EXTRA_DIST = $(PYTESTS) diff --git a/python/tests/create.py b/python/tests/create.py index b717db188..cd62928d4 100755 --- a/python/tests/create.py +++ b/python/tests/create.py @@ -12,6 +12,7 @@ if not os.access("/proc/xen", os.R_OK): # Try to provide default OS images paths here, of course non standard # osroots = [ + "/u/fc4-2.img", "/u/fc4.img", "/xen/fc4.img", ] @@ -84,7 +85,7 @@ if dom == None: print 'Failed to create a test domain' sys.exit(1) -print dom +# print dom print "Domain: id %d running %s" % (dom.ID(), dom.OSType()) diff --git a/python/tests/node.py b/python/tests/node.py new file mode 100755 index 000000000..2e33fb70c --- /dev/null +++ b/python/tests/node.py @@ -0,0 +1,34 @@ +#!/usr/bin/python -u +import libvirt +import sys +import os + +if not os.access("/proc/xen", os.R_OK): + print 'System is not running a Xen kernel' + sys.exit(1) + +conn = libvirt.openReadOnly(None) +if conn == None: + print 'Failed to open connection to the hypervisor' + sys.exit(1) + +try: + (model, memory, cpus, mhz, nodes, socket, cores, threads) = conn.getInfo() +except: + print 'Failed to extract the current node informations' + sys.exit(1) + +print "Xen running on %d %s processors at %d MHz, %d MBytes of memory" % ( + cpus, model, mhz, memory) + +if cpus > nodes * socket * cores * threads: + print "Erroneous CPU informations" + sys.exit(1) + +if cpus < nodes * socket * cores * threads: + print "Strange, running in degrated mode, some CPU are not available" + +del conn +print "OK" + +sys.exit(0) |