aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-06 19:25:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-06 19:30:18 +0200
commita083648573fc7dc31e0709d1b304d630ccf89ff1 (patch)
tree374439251d7992bed8165eede48301ed57f556de /www-client
parentkde-apps/krfb: Drop obsolete dependency (diff)
downloadkde-a083648573fc7dc31e0709d1b304d630ccf89ff1.tar.gz
kde-a083648573fc7dc31e0709d1b304d630ccf89ff1.tar.bz2
kde-a083648573fc7dc31e0709d1b304d630ccf89ff1.zip
www-client/falkon: Update dependencies, cmake args, rebase py3 patch
Upstream commits: db0584f81e6b37b3e381841b7ca34f77b4adf717 4bbe60eff05d4492ae2a1256700038eae8cf7840 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/falkon/falkon-9999.ebuild7
-rw-r--r--www-client/falkon/files/falkon-22.04.3-python3.patch32
-rw-r--r--www-client/falkon/files/falkon-23.07.80-python3.patch32
3 files changed, 35 insertions, 36 deletions
diff --git a/www-client/falkon/falkon-9999.ebuild b/www-client/falkon/falkon-9999.ebuild
index 78abf7d5a8..7d7aa6ab3e 100644
--- a/www-client/falkon/falkon-9999.ebuild
+++ b/www-client/falkon/falkon-9999.ebuild
@@ -37,6 +37,7 @@ COMMON_DEPEND="
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kcrash-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
>=kde-frameworks/kwallet-${KFMIN}:5
>=kde-frameworks/purpose-${KFMIN}:5
)
@@ -64,7 +65,7 @@ RDEPEND="${COMMON_DEPEND}
"
BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
-PATCHES=( "${FILESDIR}/${PN}-22.04.3-python3.patch" )
+PATCHES=( "${FILESDIR}/${PN}-23.07.80-python3.patch" )
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -77,9 +78,7 @@ src_configure() {
-DDISABLE_DBUS=$(usex !dbus)
$(cmake_use_find_package kde KF5Wallet)
$(cmake_use_find_package kde KF5KIO)
- $(cmake_use_find_package python PySide2)
- $(cmake_use_find_package python Shiboken2)
- $(cmake_use_find_package python Python3)
+ -DBUILD_PYTHON_SUPPORT=$(usex python)
-DNO_X11=$(usex !X)
)
use python && mycmakeargs+=(
diff --git a/www-client/falkon/files/falkon-22.04.3-python3.patch b/www-client/falkon/files/falkon-22.04.3-python3.patch
deleted file mode 100644
index cd1025cbfd..0000000000
--- a/www-client/falkon/files/falkon-22.04.3-python3.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 67199ef5f470dadab17401f3aad8770ec058c111 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Sun, 17 Jul 2022 12:45:25 +0200
-Subject: [PATCH] Python3 must be found first
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 950c03adc..aa91e745e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -130,12 +130,12 @@ if (KF5Wallet_FOUND AND KF5KIO_FOUND AND KF5Crash_FOUND AND KF5CoreAddons_FOUND
- endif()
-
- # Optional: PySide2
-+find_package(Python3 COMPONENTS Development)
- find_package(PySide2 "2.0.0")
- find_package(Shiboken2 "2.0.0")
--find_package(Python3 COMPONENTS Development)
-+set_package_properties(Python3 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
- set_package_properties(PySide2 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
- set_package_properties(Shiboken2 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
--set_package_properties(Python3 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
- if (PySide2_FOUND AND Shiboken2_FOUND AND Python3_FOUND)
- set(ENABLE_PYTHON_PLUGINS TRUE)
- endif()
---
-2.35.1
-
diff --git a/www-client/falkon/files/falkon-23.07.80-python3.patch b/www-client/falkon/files/falkon-23.07.80-python3.patch
new file mode 100644
index 0000000000..d0b0e4bad7
--- /dev/null
+++ b/www-client/falkon/files/falkon-23.07.80-python3.patch
@@ -0,0 +1,32 @@
+From 9415a9da443c9a566dd2220551928c16602fa284 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 17 Jul 2022 12:45:25 +0200
+Subject: [PATCH] Python3 must be found first
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a847838be..1b5b38bbc 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -134,12 +134,12 @@ endif()
+ # Optional: PySide2
+ option(BUILD_PYTHON_SUPPORT "Support for Python plugins" ON)
+ if (BUILD_PYTHON_SUPPORT)
++ find_package(Python3 COMPONENTS Development)
+ find_package(PySide2 "2.0.0")
+ find_package(Shiboken2 "2.0.0")
+- find_package(Python3 COMPONENTS Development)
++ set_package_properties(Python3 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+ set_package_properties(PySide2 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+ set_package_properties(Shiboken2 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+- set_package_properties(Python3 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+ if (PySide2_FOUND AND Shiboken2_FOUND AND Python3_FOUND)
+ set(ENABLE_PYTHON_PLUGINS TRUE)
+ endif()
+--
+2.41.0
+