aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-11-15 10:34:47 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-11-16 16:52:54 +0100
commit54c5c9ebbf701f9dcd9f78da9f13ae967f922243 (patch)
treea7a3c43a8302ed18eccc909fcbd3de7093723be5 /pyproject.toml
parentupdate deprecated test methods for python-3.12 compatibility (diff)
downloadjava-config-54c5c9ebbf701f9dcd9f78da9f13ae967f922243.tar.gz
java-config-54c5c9ebbf701f9dcd9f78da9f13ae967f922243.tar.bz2
java-config-54c5c9ebbf701f9dcd9f78da9f13ae967f922243.zip
Use Meson as build system
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..33e28ca
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,17 @@
+[project]
+name = 'java-config'
+dynamic = ['version']
+description = 'Java environment configuration query tool'
+readme = 'README'
+requires-python = '>=3.9'
+license = {file = "COPYING"}
+authors = [
+ {name = 'Gentoo Java Project', email = 'java@gentoo.org'},
+]
+
+[build-system]
+build-backend = 'mesonpy'
+requires = ['meson-python']
+
+[tool.meson-python.args]
+setup = ['-Dsystem-wide=false']