summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-16 16:07:55 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-03-16 16:07:55 +0100
commitcf8eec7289b232fd6e43ace9fcd8246015e2260f (patch)
treeae599c2f496b3024b4b334f61e78a5772c031af3
parentapp-editors/pluma: Version bump to 1.18.0 (diff)
downloadgentoo-mate-cf8eec7289b232fd6e43ace9fcd8246015e2260f.tar.gz
gentoo-mate-cf8eec7289b232fd6e43ace9fcd8246015e2260f.tar.bz2
gentoo-mate-cf8eec7289b232fd6e43ace9fcd8246015e2260f.zip
dev-python/python-caja: Version bump to 1.18.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/python-caja/Manifest1
-rw-r--r--dev-python/python-caja/python-caja-1.18.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-caja/Manifest b/dev-python/python-caja/Manifest
index 00db4d4..40a8912 100644
--- a/dev-python/python-caja/Manifest
+++ b/dev-python/python-caja/Manifest
@@ -1,3 +1,4 @@
DIST python-caja-1.12.0.tar.xz 265720 SHA256 5418ffcc5c4a33c15348a0f10ded161d26fd1dfb46b3f68b2c6e3d2d1a7ba975 SHA512 fbec1a7f5e560cda2b3bba41dcd93c0484f2b7b7527577a2b2114c84019203df92c136fecbbe6c889785c610035a582f1912ad7da9bb1258ada661b56edf4be7 WHIRLPOOL fdf60f678762480f0a9e5532dad08fddead1f3551b2c74d82889b597389cdf37351f9b82bdcf0420dd0505167cb890a75dda3ae5268ba502717cf020a8b922fd
DIST python-caja-1.14.0.tar.xz 279432 SHA256 441506e2fd32f77adf1d81dc9748ae27b2123c6a39dc0407932c0f10b11a02ac SHA512 835d9c1df112746fb3ecfe2e661e0c36814f3e2b21c763450354ce9bc0119d055b6773efa64d252ea8a618ec6c36e2d9cbfca698ffa6652cad0b94a499167497 WHIRLPOOL 66df5024c8e47d8973c562a5144dd872adaf02e7ba15ff0c2c4115f33dec1ee5916469d0d28458779800d9543510c557bf629feb8ba9c5360a1ff8f09b811e92
DIST python-caja-1.16.0.tar.xz 280956 SHA256 14a86d174be0af753c24425469b56432ea3fbc46d954bf06ab679613f15c0ce4 SHA512 ce82fbd6d1127df33153920fbf703f77be2e1dabeb6ba33275fb1b1ba5d8aabc96222cf42280844237f0e182b0eccf764fd8ea33a8de96e844eeb0d5ef0cd5de WHIRLPOOL af036fc96a0a7b9bf322da3c3f1474331cfeaa4ef5d51fbb4eb93a318641ed90c6330487e65b818a3101f4b74db4d9c88308d0ae3336920e23be935864582432
+DIST python-caja-1.18.0.tar.xz 282504 SHA256 45b565de9ec06c05a6f65a49099645f3e82baf588b640c23adb4ab5676474403 SHA512 3836daaa4102da10d2601bc52dd8b8336459172a8ac1275f8d5f945e37cbb41f89e7a1ff737484dd4f5374ca00a0a3c6601fe28a48d7895f8efcaf793695fbcb WHIRLPOOL fbe204dfac8315b3eebe3fa223f26e5f9330e2b83dfcc791c1774d5bf11ab1ef0123dabedeaeeafec747bb6e0b8156878e6c79b18bde33dc47c24cffcad55fce
diff --git a/dev-python/python-caja/python-caja-1.18.0.ebuild b/dev-python/python-caja/python-caja-1.18.0.ebuild
new file mode 100644
index 0000000..f30cc7c
--- /dev/null
+++ b/dev-python/python-caja/python-caja-1.18.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Python bindings for the Caja file manager"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="doc"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/glib:2
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=mate-base/caja-1.17.1[introspection]
+ x11-libs/gtk+:3"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ virtual/pkgconfig:*
+ doc? ( app-text/docbook-xml-dtd:4.1.2 )"
+
+src_install() {
+ mate_src_install
+
+ # Keep the directory for systemwide extensions.
+ keepdir /usr/share/python-caja/extensions/
+
+ # The HTML documentation generation is broken and commented out by upstream.
+ #
+ #if use doc ; then
+ # insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ # doins -r docs/html/*
+ #fi
+}