aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2022-01-30 02:41:49 -0500
committerMike Frysinger <vapier@gentoo.org>2022-01-30 02:41:49 -0500
commit733d554fe2d1774f56dcf16f0b90e7f985e3abc2 (patch)
tree7d158aa327b8e9b8497042b4c6e0fc3def12b99e
parentautoconf-wrapper: ignore $KNOWN_AUTOCONF in env (diff)
downloadautotools-wrappers-733d554fe2d1774f56dcf16f0b90e7f985e3abc2.tar.gz
autotools-wrappers-733d554fe2d1774f56dcf16f0b90e7f985e3abc2.tar.bz2
autotools-wrappers-733d554fe2d1774f56dcf16f0b90e7f985e3abc2.zip
autoconf-wrapper: clean up old error message
Unwrap it a bit to take up fewer lines while still fitting within a reasonable line length, and fix the grammar in a number of places. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rwxr-xr-xac-wrapper.sh10
1 files changed, 5 insertions, 5 deletions
diff --git a/ac-wrapper.sh b/ac-wrapper.sh
index acc6fe9..ca23928 100755
--- a/ac-wrapper.sh
+++ b/ac-wrapper.sh
@@ -146,11 +146,11 @@ generated_version() {
# autodetect routine
#
if [ "${WANT_AUTOCONF}" = "2.1" ] && [ -f "configure.ac" ] ; then
- err "Since configure.ac is present, aclocal always use\n" \
- "\tautoconf 2.59+, which conflicts with your choice and\n" \
- "\tcauses error. You have two options:\n" \
- "\t1. Try execute command again after removing configure.ac\n" \
- "\t2. Don't set WANT_AUTOCONF"
+ err \
+ "Since configure.ac is present, aclocal will always use autoconf 2.59+\n" \
+ "\twhich conflicts with your choice and causes errors. You have two options:\n" \
+ "\t1. Try executing the command again after removing configure.ac\n" \
+ "\t2. Don't set WANT_AUTOCONF (currently set to '${WANT_AUTOCONF}')"
fi
if [ "${WANT_AUTOCONF:-2.1}" = "2.1" ] && [ -n "${WANT_AUTOMAKE}" ] ; then