aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Keith <tkeith@nvidia.com>2020-05-11 11:38:53 -0700
committerTim Keith <tkeith@nvidia.com>2020-05-11 11:49:25 -0700
commit99aa87a5b5371b3c06480e3ff99dcc4f2adf2c2a (patch)
treeca343a6197e829810c0769a0c1c807b0e7cd6e58 /flang/test/Semantics/modfile11.f90
parent[AArch64][GlobalISel] Make LR livein to entry in llvm.returnaddress selection (diff)
downloadllvm-project-99aa87a5b5371b3c06480e3ff99dcc4f2adf2c2a.tar.gz
llvm-project-99aa87a5b5371b3c06480e3ff99dcc4f2adf2c2a.tar.bz2
llvm-project-99aa87a5b5371b3c06480e3ff99dcc4f2adf2c2a.zip
[flang][NFC] Simplify semantics test scripts
There were several different ways of handling the option to f18 to find predefined modules: - test_errors.sh was created by cmake substituting FLANG_INTRINSIC_MODULES_DIR into test_errors.sh.in - some tests used the flang script which has the option built it - some tests used %f18_with_includes which was replaced by the path to f18 plus the -I option - some included -I../../include/flang in their run command To make this more consistent, change %f18 to include the -intrinsic-module-directory option and use it everywhere, including to replace %flang and %f18_with_includes. This requires changing all of the invocations of the test scripts to put %f18 at the end so that it can expand to more than one argument. This eliminates the need to generate test_errors.sh which means we don't need flang/test/Semantics/CMakeLists.txt or the %B substitution. That makes the test_errors.sh command like the others, replacing %B/test/Semantics/test_errors.sh with %S/test_errors.sh. Also remove the OPTIONS: functionality as custom options can be included in the RUN: command. And remove -I/../../include/flang as that is now always included. Differential Revision: https://reviews.llvm.org/D79634
Diffstat (limited to 'flang/test/Semantics/modfile11.f90')
-rw-r--r--flang/test/Semantics/modfile11.f902
1 files changed, 1 insertions, 1 deletions
diff --git a/flang/test/Semantics/modfile11.f90 b/flang/test/Semantics/modfile11.f90
index ec4dd2f88099..3259a5fb5ee6 100644
--- a/flang/test/Semantics/modfile11.f90
+++ b/flang/test/Semantics/modfile11.f90
@@ -1,4 +1,4 @@
-! RUN: %S/test_modfile.sh %s %f18 %t
+! RUN: %S/test_modfile.sh %s %t %f18
module m
type t1(a, b, c)
integer, kind :: a