aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-01-05 13:28:45 -0500
committerMichał Górny <mgorny@gentoo.org>2022-03-16 17:53:48 +0100
commit35fa499e93301cf2c94b64a04abd9c6528a61e85 (patch)
treed931a6ee0e53d90eae9a23eda4217ec059cf7d7c /Makefile.pre.in
parentPython 3.8.13, take two (diff)
downloadcpython-35fa499e93301cf2c94b64a04abd9c6528a61e85.tar.gz
cpython-35fa499e93301cf2c94b64a04abd9c6528a61e85.tar.bz2
cpython-35fa499e93301cf2c94b64a04abd9c6528a61e85.zip
Install libpythonX.Y.a in /usr/lib instead of /usr/lib/pythonX.Y/config
https://bugs.gentoo.org/show_bug.cgi?id=252372 https://bugs.python.org/issue6103
Diffstat (limited to 'Makefile.pre.in')
-rw-r--r--Makefile.pre.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.pre.in b/Makefile.pre.in
index 7e381283fee..37cbb028904 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -1582,9 +1582,9 @@ libainstall: @DEF_MAKE_RULE@ python-config
@if test -d $(LIBRARY); then :; else \
if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
if test "$(SHLIB_SUFFIX)" = .dll; then \
- $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+ $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBDIR) ; \
else \
- $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBDIR)/$(LIBRARY) ; \
fi; \
else \
echo Skip install of $(LIBRARY) - use make frameworkinstall; \