aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-07 00:15:53 -0500
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-01-29 17:16:29 +0100
commit47a875bb7afc3673b8c9e14f57ede7867c6e7a04 (patch)
treeada5519783fc877cbd3167a8ddbb7e53e5b41e5a
parentGentoo: gold/ld: add support for poisoned system directories (diff)
downloadbinutils-gdb-47a875bb7afc3673b8c9e14f57ede7867c6e7a04.tar.gz
binutils-gdb-47a875bb7afc3673b8c9e14f57ede7867c6e7a04.tar.bz2
binutils-gdb-47a875bb7afc3673b8c9e14f57ede7867c6e7a04.zip
Gentoo: libiberty: install PIC version of libiberty.a
This will install a PIC version of libiberty.a by overwriting the non-PIC version of libiberty.a while compiling. We do this because there is no shared version of libiberty for random apps to link against which means if someone wants to use this in a shared library or PIE, they're out of luck. It's arguable whether people should be able to use this in a shared lib, but usage in PIE should be fine. You could argue that this penalizes the non-PIE users, but the counter point is that people using this library in general are fairly low, and we'd rather have things work for all of them. (cherry picked from commit 112aff9ad3e2675556370c4281117a6df0a879d9)
-rw-r--r--libiberty/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/libiberty/Makefile.in b/libiberty/Makefile.in
index 85c4b6b6ef8..474f2ea9b35 100644
--- a/libiberty/Makefile.in
+++ b/libiberty/Makefile.in
@@ -258,6 +258,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
$(AR) $(AR_FLAGS) $(TARGETLIB) \
$(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
$(RANLIB) $(TARGETLIB); \
+ cp $(TARGETLIB) ../ ; \
cd ..; \
else true; fi; \
if [ x"$(NOASANFLAG)" != x ]; then \