aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-07 00:15:53 -0500
committerSergei Trofimovich <slyfox@gentoo.org>2019-02-16 10:10:21 +0000
commiteee992c95d0c34e6b52d0062aafb19fee8fd9d72 (patch)
treeedcfefba18daa0c6aa661bbf8e17706616796f49
parentGentoo: ld: enable new dtags by default for linux/gnu targets (diff)
downloadbinutils-gdb-eee992c95d0c34e6b52d0062aafb19fee8fd9d72.tar.gz
binutils-gdb-eee992c95d0c34e6b52d0062aafb19fee8fd9d72.tar.bz2
binutils-gdb-eee992c95d0c34e6b52d0062aafb19fee8fd9d72.zip
Gentoo: libiberty: install PIC version of libiberty.a
This will install a PIC version of libiberty.a by overwriting the non-PIC version of libiberty.a while compiling. We do this because there is no shared version of libiberty for random apps to link against which means if someone wants to use this in a shared library or PIE, they're out of luck. It's arguable whether people should be able to use this in a shared lib, but usage in PIE should be fine. You could argue that this penalizes the non-PIE users, but the counter point is that people using this library in general are fairly low, and we'd rather have things work for all of them. (cherry picked from commit 112aff9ad3e2675556370c4281117a6df0a879d9)
-rw-r--r--libiberty/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/libiberty/Makefile.in b/libiberty/Makefile.in
index 0be45b4ae8e..62cc6fa6e4e 100644
--- a/libiberty/Makefile.in
+++ b/libiberty/Makefile.in
@@ -254,6 +254,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
$(AR) $(AR_FLAGS) $(TARGETLIB) \
$(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
$(RANLIB) $(TARGETLIB); \
+ cp $(TARGETLIB) ../ ; \
cd ..; \
else true; fi; \
if [ x"$(NOASANFLAG)" != x ]; then \