summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xlrd/xlrd-0.7.1-r256.ebuild')
-rw-r--r--dev-python/xlrd/xlrd-0.7.1-r256.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/xlrd/xlrd-0.7.1-r256.ebuild b/dev-python/xlrd/xlrd-0.7.1-r256.ebuild
index b058ea9..f954a22 100644
--- a/dev-python/xlrd/xlrd-0.7.1-r256.ebuild
+++ b/dev-python/xlrd/xlrd-0.7.1-r256.ebuild
@@ -4,9 +4,6 @@
EAPI="4"
-#USE_PYTHON="python25 python26 python27"
-PYTHON_OPTIONAL="no"
-
inherit python-distutils-ng
DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
@@ -21,43 +18,14 @@ IUSE="examples"
DEPEND=""
RDEPEND=""
-python_unpack_all() {
- : echo " ### python_unpack_all ### (${@}) PYTHON=${PYTHON}"
- unpack ${A} # Not needed
-}
-
python_prepare_all() {
- : echo " ### python_prepare_all ### (${@}) PYTHON=${PYTHON}"
sed -i \
-e "s,'doc,# 'doc,g" \
-e "s,'exa,# 'exa,g" \
setup.py || die
}
-python_prepare() {
- : echo " ### python_prepare ### (${@}) PYTHON=${PYTHON}"
-}
-
-python_configure() {
- : echo " ### python_configure ### (${@}) PYTHON=${PYTHON}"
-}
-
-python_compile() {
- : echo " ### python_compile ### (${@}) PYTHON=${PYTHON}"
- ${PYTHON} setup.py build || die
-}
-
-python_test() {
- : echo " ### python_test ### (${@}) PYTHON=${PYTHON}"
-}
-
-python_install() {
- : echo " ### python_install ### (${@}) PYTHON=${PYTHON}"
- ${PYTHON} setup.py install --no-compile --root="${D}/" || die
-}
-
python_install_all() {
- : echo " ### python_install_all ### (${@}) PYTHON=${PYTHON}"
rm -f "${D}/usr/bin"/*.py || die
python-distutils-ng_doscript scripts/runxlrd.py