From cf97cba9590f39623669a680038e1c77f7f6a954 Mon Sep 17 00:00:00 2001
From: Luca Barbato <lu_zero@gentoo.org>
Date: Tue, 18 Nov 2003 23:43:17 +0000
Subject: 2.6 fix (~ppc)

---
 app-emulation/mol/ChangeLog               |  5 ++-
 app-emulation/mol/Manifest                |  5 ++-
 app-emulation/mol/files/26-arch-fix.patch | 68 +++++++++++++++++++++++++++++++
 app-emulation/mol/mol-0.9.69_pre6.ebuild  | 21 ++++++++--
 4 files changed, 92 insertions(+), 7 deletions(-)
 create mode 100644 app-emulation/mol/files/26-arch-fix.patch

(limited to 'app-emulation/mol')

diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 92af80938c79..16acc3a54d95 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,9 @@
 # ChangeLog for app-emulation/mol
 # Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.25 2003/11/14 20:07:36 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.26 2003/11/18 23:43:00 lu_zero Exp $
+
+  19 Nov 2003; Luca Barbato <lu_zero@gentoo.org> mol-0.9.69_pre6.ebuild:
+  linux 2.6 fix (as patch)
 
 *mol-0.9.69_pre6 (14 Nov 2003)
 
diff --git a/app-emulation/mol/Manifest b/app-emulation/mol/Manifest
index 2e4fc5ca9933..d21abe385958 100644
--- a/app-emulation/mol/Manifest
+++ b/app-emulation/mol/Manifest
@@ -1,9 +1,10 @@
-MD5 6c6484c67f6e56708f51f73c96ee2cdc ChangeLog 4909
+MD5 d587c5f0bff233769be3f05cf8b658da ChangeLog 5010
 MD5 3263d375abba2d098c636efc2b135ea5 metadata.xml 333
 MD5 f6f3a86ce2df00004b9bfd5a8b309bf7 mol-0.9.69_pre3.ebuild 2255
 MD5 84c32ed763ae9c3851d03607a6bd1684 mol-0.9.68-r4.ebuild 2217
 MD5 d7e93f442ec1c3255e5db4e50fc74228 mol-0.9.69_pre5.ebuild 3064
-MD5 366f5d044905c938585e2100a14aa221 mol-0.9.69_pre6.ebuild 3064
+MD5 5dd60ac42574b946fd65a5fea3d8ca0e mol-0.9.69_pre6.ebuild 3304
+MD5 98990df6bb9f196021dea0b77d2d912d files/26-arch-fix.patch 2320
 MD5 fe988b32af2da567155820691a274880 files/digest-mol-0.9.69_pre3 69
 MD5 d4bc3f0122eb77fbfbfcf584f442049d files/digest-mol-0.9.68-r4 67
 MD5 73f8102dcdc9e7701ece91d0f38fb513 files/digest-mol-0.9.69_pre5 69
diff --git a/app-emulation/mol/files/26-arch-fix.patch b/app-emulation/mol/files/26-arch-fix.patch
new file mode 100644
index 000000000000..99e6459ce871
--- /dev/null
+++ b/app-emulation/mol/files/26-arch-fix.patch
@@ -0,0 +1,68 @@
+diff -ruN mol-0.9.69_pre6.orig/configure.in mol-0.9.69_pre6/configure.in
+--- mol-0.9.69_pre6.orig/configure.in	2003-11-18 22:35:10.000000000 +0100
++++ mol-0.9.69_pre6/configure.in	2003-11-18 23:02:40.000000000 +0100
+@@ -96,30 +96,30 @@
+ case "$host_cpu-$host_os" in 
+      i?86-*linux*)
+ 	Arch=Linux
+-        ARCH=i386-linux ;;
++        ARCH_=i386-linux ;;
+      powerpc-*linux* | ppc-*linux*)
+ 	Arch=Linux
+-        ARCH=ppc-linux
++        ARCH_=ppc-linux
+         AC_DEFINE(NATIVE_PPC, 1, [Define if native PPC] ) ;;
+      powerpc-*darwin*)
+ 	Arch=Darwin
+ 	AC_DEFINE(__darwin__, 1, [Define if running Darwin] ) 
+-        ARCH=darwin ;;
++        ARCH_=darwin ;;
+      *)
+         AC_MSG_ERROR([Unsupported architecture $host_cpu-$host_os ]) ;;
+ esac
+ 
+ case "$host_os" in *linux*) OS=linux ;; esac
+ 
+-AM_CONDITIONAL(ARCH_386_LINUX, test $ARCH = i386-linux )
+-AM_CONDITIONAL(ARCH_PPC_LINUX, test $ARCH = ppc-linux )
+-AM_CONDITIONAL(ARCH_DARWIN, test $ARCH = darwin )
++AM_CONDITIONAL(ARCH_386_LINUX, test $ARCH_ = i386-linux )
++AM_CONDITIONAL(ARCH_PPC_LINUX, test $ARCH_ = ppc-linux )
++AM_CONDITIONAL(ARCH_DARWIN, test $ARCH_ = darwin )
+ AM_CONDITIONAL(CPU_386, test $CPU = i386 )
+ AM_CONDITIONAL(CPU_PPC, test $CPU = ppc )
+ AM_CONDITIONAL(LINUX, test "$OS" = linux )
+ 
+ AC_SUBST(Arch)
+-AC_SUBST(ARCH)
++AC_SUBST(ARCH_)
+ AC_SUBST(CPU)
+ 
+ 
+@@ -206,7 +206,7 @@
+ ################################################################################
+ 
+ AC_ARG_ENABLE(oldworld, [  --disable-oldworld      don not include oldworld support], [], [])
+-test $ARCH = darwin && enable_oldworld=no
++test $ARCH_ = darwin && enable_oldworld=no
+ 
+ AM_CONDITIONAL(OLDWORLD_SUPPORT, test "$enable_oldworld" != no )
+ test "$enable_oldworld" != no && {
+@@ -231,7 +231,7 @@
+ #}
+ 
+ AC_ARG_ENABLE(esound, [  --disable-alsa          disable ALSA sound driver support], [], [])
+-test $ARCH = darwin && enable_alsa=no
++test $ARCH_ = darwin && enable_alsa=no
+ 
+ test "$enable_alsa" != no && {
+      AC_CHECK_LIB(asound, snd_pcm_open, [LIB_ALSA=-lasound], [enable_alsa=no])
+@@ -510,7 +510,7 @@
+ 
+ CFLAGS="$CFLAGS -Wall -Wmissing-prototypes "'$(UNIMPORTANT_CFLAGS)'
+ #CFLAGS="$CFLAGS -fno-strict-aliasing"
+-test $ARCH = darwin && CFLAGS="$CFLAGS -traditional-cpp"
++test $ARCH_ = darwin && CFLAGS="$CFLAGS -traditional-cpp"
+ 
+ ASMFLAGS=
+ AC_SUBST(ASMFLAGS)
diff --git a/app-emulation/mol/mol-0.9.69_pre6.ebuild b/app-emulation/mol/mol-0.9.69_pre6.ebuild
index 188b62427f9b..0acdc70d0995 100644
--- a/app-emulation/mol/mol-0.9.69_pre6.ebuild
+++ b/app-emulation/mol/mol-0.9.69_pre6.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2003 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.69_pre6.ebuild,v 1.1 2003/11/14 20:07:36 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.69_pre6.ebuild,v 1.2 2003/11/18 23:43:00 lu_zero Exp $
 
 inherit flag-o-matic
 
@@ -20,6 +20,12 @@ LICENSE="GPL-2"
 KEYWORDS="~ppc -x86 -sparc -alpha -mips"
 IUSE="alsa esd debug oldworld X"
 
+src_unpack() {
+	unpack ${A}
+	cd ${S}
+	epatch ${FILESDIR}/26-arch-fix.patch || die
+}
+
 src_compile() {
 
 	local myconf
@@ -28,6 +34,11 @@ src_compile() {
 	use esd      && myconf="${myconf} --enable-esd"
 	use oldworld || myconf="${myconf} --disable-oldworld"
 	use X        && myconf="${myconf} --with-x"
+	
+	#workaround
+	[ "`echo ${KV}|grep 2.6`" ] \
+	&& myconf="${myconf} --disable-sheep" \
+	&& einfo "sheep.ko module won't build, disabling"
 
 	einfo "MOL will be build with the following options:"
 	einfo "${myconf}"
@@ -39,13 +50,12 @@ src_compile() {
 	sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die
 	sed -i "s:DHCPD\ -q\ -cf:DHCPD\ -cf:g" Doc/config/tunconfig || die
 	export KERNEL_SOURCE="/usr/src/linux"
-	export ARCH=ppc
 	./autogen.sh
 	./configure ${myconf} --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
 
 	addwrite "/usr/src/${FK}"
 
-	emake ARCH=ppc || die
+	emake || die
 }
 
 src_install() {
@@ -53,9 +63,12 @@ src_install() {
 	# MOL needs write access to some .depend-files in the kernel-dir
 	# (at least arch/ppc/) to build the kernel-modules.  With
 	# sandboxing enabled this would result in an access violation.
-
+	
+	addwrite "/usr/src/${FK}"
 	emake DESTDIR=${D} install || die "Failed to install MOL"
 
+	#workaround
+	
 	dodoc 0README BUILDING COPYRIGHT CREDITS Doc/*
 
 }
-- 
cgit v1.2.3-65-gdbad