summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lm-sensors/ChangeLog8
-rw-r--r--sys-apps/lm-sensors/files/digest-lm-sensors-2.8.81
-rw-r--r--sys-apps/lm-sensors/files/lm-sensors-2.8.8-sensors-detect-gentoo.diff119
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild6
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild154
5 files changed, 284 insertions, 4 deletions
diff --git a/sys-apps/lm-sensors/ChangeLog b/sys-apps/lm-sensors/ChangeLog
index 702be094924d..fe31c740bf29 100644
--- a/sys-apps/lm-sensors/ChangeLog
+++ b/sys-apps/lm-sensors/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/lm-sensors
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/ChangeLog,v 1.38 2004/09/26 22:00:39 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/ChangeLog,v 1.39 2004/10/24 11:41:46 plasmaroo Exp $
+
+*lm-sensors-2.8.8 (24 Oct 2004)
+
+ 24 Oct 2004; <plasmaroo@gentoo.org> +lm-sensors-2.8.8.ebuild,
+ +files/lm-sensors-2.8.8-sensors-detect-gentoo.diff:
+ Version bump - bug #67587.
26 Sep 2004; Danny van Dyk <kugelfang@gentoo.org> lm-sensors-2.8.7.ebuild:
Marked stable on amd64.
diff --git a/sys-apps/lm-sensors/files/digest-lm-sensors-2.8.8 b/sys-apps/lm-sensors/files/digest-lm-sensors-2.8.8
new file mode 100644
index 000000000000..5f9606d03928
--- /dev/null
+++ b/sys-apps/lm-sensors/files/digest-lm-sensors-2.8.8
@@ -0,0 +1 @@
+MD5 95cdb083b4d16e2419a2c78b35f608d0 lm_sensors-2.8.8.tar.gz 820983
diff --git a/sys-apps/lm-sensors/files/lm-sensors-2.8.8-sensors-detect-gentoo.diff b/sys-apps/lm-sensors/files/lm-sensors-2.8.8-sensors-detect-gentoo.diff
new file mode 100644
index 000000000000..a35525fa3107
--- /dev/null
+++ b/sys-apps/lm-sensors/files/lm-sensors-2.8.8-sensors-detect-gentoo.diff
@@ -0,0 +1,119 @@
+--- lm_sensors-2.8.8/prog/detect/sensors-detect 2004-10-03 21:51:47.000000000 +0100
++++ lm_sensors-2.8.8/prog/detect/sensors-detect.plasmaroo 2004-10-24 12:33:39.837299960 +0100
+@@ -26,6 +26,14 @@
+ # each be put in a separate file, using modules and packages. That is beyond
+ # me.
+
++# Changelog
++# 02/Mar/2003, Rudo Thomas <thomr9am@ss1000.ms.mff.cuni.cz>
++# * a few small changes in config file output to reflect Gentoo Linux layout
++# - /etc/sysconfig -> /etc/conf.d
++# - /etc/rc.d/init.d -> /etc/init.d
++# - added a warning to the generated config file
++# - small change when asking about writing the new config file
++
+ require 5.004;
+
+ use strict;
+@@ -4882,39 +4890,44 @@
+ my $use_isa = not <STDIN> =~ /\s*[Ss]/;
+
+ my ($modprobes,$configfile) = generate_modprobes $use_isa;
++ print "\nIf you want to load the modules at startup, generate a config file\n",
++ "below and make sure lm_sensors gets started; e.g\n",
++ "\$ rc-update add lm_sensors default.\n";
+ print "\nTo make the sensors modules behave correctly, add these lines to\n",
+- "$modules_conf:\n\n";
++ "/etc/modules.conf:\n\n";
+ print "#----cut here----\n";
+ print $configfile;
+- print "#----cut here----\n";
+- print "\nTo load everything that is needed, add this to some /etc/rc* ",
+- "file:\n\n";
+- print "#----cut here----\n";
+- print $modprobes;
+- print "# sleep 2 # optional\n",
+- "/usr/local/bin/sensors -s # recommended\n";
+- print "#----cut here----\n";
++ print "#----end cut here----\n";
+ print "\nWARNING! If you have some things built into your kernel, the list above\n",
+ "will contain too many modules. Skip the appropriate ones! You really should\n",
+ "try these commands right now to make sure everything is working properly.\n",
+ "Monitoring programs won't work until it's done.\n";
+-
+- my $have_sysconfig = -d '/etc/sysconfig';
+- print "\nDo you want to generate /etc/sysconfig/lm_sensors? (".
+- ($have_sysconfig?"YES/no":"yes/NO")."): ";
+- if ($> != 0) {
+- print "\nAs you are not root, we shall skip this step.\n";
+- } else {
+- $_ = <STDIN>;
+- if (($have_sysconfig and not m/^\s*[Nn]/) or m/^\s*[Yy]/) {
+- unless ($have_sysconfig) {
+- mkdir '/etc/sysconfig', 0777
+- or die "Sorry, can't create /etc/sysconfig ($!)?!?";
+- }
+- open(local *SYSCONFIG, ">/etc/sysconfig/lm_sensors")
+- or die "Sorry, can't create /etc/sysconfig/lm_sensors ($!)?!?";
+- print SYSCONFIG <<'EOT';
+-# /etc/sysconfig/sensors - Defines modules loaded by /etc/rc.d/init.d/lm_sensors
++
++ print "To load everything that is needed, execute the commands above...";
++
++ print "\n\n#----cut here----\n";
++ print $modprobes;
++ print "# sleep 2 # optional\n",
++ "/usr/bin/sensors -s # recommended\n";
++
++ my $have_config = -f '/etc/conf.d/lm_sensors';
++ print "\nDo you want to ".($have_config?"overwrite":"generate").
++ " /etc/conf.d/lm_sensors? Enter s to specify other file name?\n",
++ " (".($have_config?"yes/NO":"YES/no")."/s): ";
++ my $reply = <STDIN>;
++
++ if (($have_config and $reply =~ /^\s*[Yy]/) or
++ (not $have_config and not $reply =~ /^\s*[Nn]/) or
++ $reply =~ /^\s*[Ss]/) {
++ my $filename = "/etc/conf.d/lm_sensors";
++ if ($reply =~ /^\s*[Ss]/) {
++ print "Specify the file to store the configuration to: ";
++ $filename = <STDIN>;
++ }
++ open(SYSCONFIG, ">".$filename)
++ or die "Sorry, can't create $filename ($!).";
++ print SYSCONFIG <<'EOT';
++# /etc/conf.d/sensors - Defines modules loaded by /etc/init.d/lm_sensors
+ # Copyright (c) 1998 - 2001 Frodo Looijaard <frodol@dds.nl>
+ #
+ # This program is free software; you can redistribute it and/or modify
+@@ -4935,13 +4948,17 @@
+ # See also the lm_sensors homepage at:
+ # http://www2.lm-sensors.nu/~lm78/index.html
+ #
+-# This file is used by /etc/rc.d/init.d/lm_sensors and defines the modules to
+-# be loaded/unloaded. This file is sourced into /etc/rc.d/init.d/lm_sensors.
++# This file is used by /etc/init.d/lm_sensors and defines the modules to
++# be loaded/unloaded. This file is sourced into /etc/init.d/lm_sensors.
+ #
+ # The format of this file is a shell script that simply defines the modules
+ # in order as normal variables with the special names:
+ # MODULE_0, MODULE_1, MODULE_2, etc.
+ #
++# Please note that the numbers in MODULE_X must start at 0 and increase in
++# steps of 1. Any number that is missing will make the init script skip the
++# rest of the modules. Use MODULE_X_ARGS for arguments.
++#
+ # List the modules that are to be loaded for your system
+ #
+ EOT
+@@ -4956,9 +4973,7 @@
+ $i++;
+ }
+ print SYSCONFIG $sysconfig;
+- print "Copy prog/init/lm_sensors.init to /etc/rc.d/init.d/lm_sensors\n";
+- print "for initialization at boot time.\n";
+- }
++ print "Done.\n";
+ }
+ }
+
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild
index 6532792d2511..6bbf97d67e33 100644
--- a/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild,v 1.5 2004/09/26 22:00:39 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild,v 1.6 2004/10/24 11:41:46 plasmaroo Exp $
inherit flag-o-matic eutils
@@ -15,11 +15,11 @@ HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
SLOT="${KV}"
KEYWORDS="-ppc -sparc x86 amd64"
-IUSE=""
+IUSE="rrdtool"
LICENSE="GPL-2"
DEPEND=">=sys-apps/i2c-${PV}
- rrdtool? ( net-analyzer/rrdtool )"
+ rrdtool? ( x86? ( net-analyzer/rrdtool ) )"
src_unpack() {
unpack ${A} || die
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild
new file mode 100644
index 000000000000..1e32f609feef
--- /dev/null
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild,v 1.1 2004/10/24 11:41:46 plasmaroo Exp $
+
+inherit flag-o-matic eutils
+
+MY_P=${PN/-/_}-${PV}
+S="${WORKDIR}/${MY_P}"
+MYI2C="${WORKDIR}/i2c-headers"
+
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www.lm-sensors.nu/archive/${MY_P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+
+SLOT="${KV}"
+
+KEYWORDS="~x86"
+IUSE="rrdtool"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-apps/i2c-${PV}
+ rrdtool? ( net-analyzer/rrdtool )"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/${P}-sensors-detect-gentoo.diff > /dev/null || die
+
+ # Get the right I2C includes without dropping the kernel includes
+ mkdir -p ${MYI2C}/linux
+ cp /usr/include/linux/i2c* ${MYI2C}/linux/
+
+ # Add sensord to the make targets if the rrdtool USE flag is on...
+ use rrdtool && sed -i -e 's:# PROG_EXTRA:PROG_EXTRA:' Makefile
+}
+
+src_compile() {
+ echo
+ einfo "*****************************************************************"
+ einfo
+ einfo "This ebuild assumes your /usr/src/linux kernel is the one you"
+ einfo "used to build i2c-2.8.8."
+ einfo
+ einfo "For 2.5+ series kernels, use the support already in the kernel"
+ einfo "under 'Character devices' -> 'I2C support' and then merge this"
+ einfo "ebuild."
+ einfo
+ einfo "To cross-compile, 'export LINUX=\"/lib/modules/<version>/build\"'"
+ einfo "or symlink /usr/src/linux to another kernel."
+ einfo
+ einfo "*****************************************************************"
+ echo
+
+ UserModeOnly=false
+ if [ "$LINUX" != "" ]; then
+ einfo "Cross-compiling using:- $LINUX"
+ LINUX=`echo $LINUX | sed 's/build\//build/'`
+ KV=`cut -d\ -f3 ${LINUX}/include/linux/version.h | grep \" | sed -e 's/"//' -e 's/"//'`
+ if [ "${KV}" == "" ]; then
+ die "Could not get kernel version; make sure ${LINUX}/include/linux/version.h is there!"
+ fi
+ else
+ LINUX='/usr/src/linux'
+ check_KV || die "Cannot find kernel in /usr/src/linux!"
+ einfo "Using kernel in /usr/src/linux/:- ${KV}"
+ fi
+ if [ `echo ${KV} | grep 2\.[56]\.` ]; then
+ einfo "You are using a 2.5 / 2.6 series kernel; only building utilities..."
+ UserModeOnly=true
+ else
+ einfo "You are using a `echo ${KV} | cut -d. -f-2` series kernel; building everything..."
+ fi
+ if [ "${KV}" != "${SLOT}" ]; then
+ echo
+ ewarn "WARNING:- Specified and running kernels do not match!"
+ ewarn "WARNING:- This package will be slotted as ${SLOT}!"
+ fi
+
+ if [ ! -e ${MYI2C}/linux/i2c.h ]; then
+ cp $LINUX/include/linux/i2c* ${MYI2C}/linux || die "No I2C Includes! Install I2C!"
+ fi
+
+ echo; einfo "You may safely ignore any errors from compilation"
+ einfo "that contain 'No such file' references."
+
+ echo
+
+ # Please _don't_ use filter-flags -fPIC on apps that need it!
+ # [ amd64, hppa, ia64, etc... ]
+ # Danny van Dyk <kugelfang@gentoo.org> 2004/05/28
+ case "${ARCH}" in
+ "amd64")
+ filter-flags -fstack-protector
+ ;;
+ *)
+ filter-flags -fPIC -fstack-protector
+ ;;
+ esac
+
+ cd ${S}
+ emake clean
+
+ if [ ${UserModeOnly} == true ]; then
+ emake CC=${CC} I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ else
+ emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ fi
+}
+
+src_install() {
+
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/sbin
+ if [ ${UserModeOnly} == true ]; then
+ emake DESTDIR=${D} PREFIX=${D}/usr MANDIR=${D}/usr/share/man user_install || die "Install failed!"
+ else
+ emake LINUX=$LINUX DESTDIR=${D} PREFIX=${D}/usr MANDIR=${D}/usr/share/man install || die "Install failed!"
+ fi
+ cp ${D}/${D}* ${D} -Rf
+ rm ${D}/var -Rf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc lm_sensors
+ dodoc BACKGROUND BUGS CHANGES CONTRIBUTORS COPYING INSTALL QUICKSTART \
+ README* TODO
+ cp -a doc/* ${D}/usr/share/doc/${PF}
+
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ echo
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+ echo
+}