summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/externaleditor/externaleditor-0.8.ebuild')
-rw-r--r--net-zope/externaleditor/externaleditor-0.8.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/net-zope/externaleditor/externaleditor-0.8.ebuild b/net-zope/externaleditor/externaleditor-0.8.ebuild
index 28b54967d9f5..466e02bc3910 100644
--- a/net-zope/externaleditor/externaleditor-0.8.ebuild
+++ b/net-zope/externaleditor/externaleditor-0.8.ebuild
@@ -1,25 +1,25 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/externaleditor/externaleditor-0.8.ebuild,v 1.5 2005/05/06 14:54:33 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/externaleditor/externaleditor-0.8.ebuild,v 1.6 2006/01/27 02:31:53 vapier Exp $
inherit zproduct
MY_PN="ExternalEditor"
MY_P="${MY_PN}-${PV}-src"
MY_P2="zopeedit-${PV}-src"
-DESCRIPTION="Allows you to use your favorite editor(s) from ZMI."
+DESCRIPTION="Allows you to use your favorite editor(s) from ZMI"
HOMEPAGE="http://www.zope.org/Members/Caseman/${MY_PN}/"
SRC_URI_BASE="${HOMEPAGE}/${PV}"
SRC_URI="${SRC_URI_BASE}/${MY_P}.tgz
${SRC_URI_BASE}/${MY_P2}.tgz"
+
LICENSE="ZPL"
-KEYWORDS="x86 ppc ~sparc ~amd64"
-IUSE=""
-ZPROD_LIST="${MY_PN}"
+KEYWORDS="~amd64 ppc ~sparc x86"
# the base of teh application is in Python2.1, but zopeedit.py wants Python2.2
-RDEPEND="${RDEPEND}
- >=dev-lang/python-2.2"
+RDEPEND=">=dev-lang/python-2.2"
+
+ZPROD_LIST="${MY_PN}"
S_ZPROD=${WORKDIR}/${MY_PN}
S_SRC=${WORKDIR}/${MY_P2}
@@ -36,8 +36,7 @@ src_unpack() {
DOCDIR=/usr/share/doc/${PF}
-src_install()
-{
+src_install() {
S=${S_ZPROD} zproduct_src_install
mkdir -p ${T}${DOCDIR}/${MY_PN}
mv ${D}${DOCDIR}/* ${T}${DOCDIR}/${MY_PN}
@@ -52,8 +51,7 @@ src_install()
doins Plugins/*.py
}
-pkg_postinst()
-{
+pkg_postinst() {
zproduct_pkg_postinst
ewarn "To use the External Editor Zope Product you will need to manually"
ewarn "configure the helper application(/usr/bin/zopeedit.py) for your"