summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ircii/ChangeLog8
-rw-r--r--net-irc/ircii/ircii-20111115.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/net-irc/ircii/ChangeLog b/net-irc/ircii/ChangeLog
index 39b12be1e19a..baf1196a46f9 100644
--- a/net-irc/ircii/ChangeLog
+++ b/net-irc/ircii/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/ircii
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ChangeLog,v 1.28 2011/06/30 03:00:37 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ChangeLog,v 1.29 2011/12/02 00:17:56 binki Exp $
+
+*ircii-20111115 (02 Dec 2011)
+
+ 02 Dec 2011; Nathan Phillip Brink <binki@gentoo.org> +ircii-20111115.ebuild:
+ Bump to ircii-20111115, which was released to address the glibc
+ incompatibility.
30 Jun 2011; Nathan Phillip Brink <binki@gentoo.org> ircii-20110228.ebuild:
Import modifications necessary for prefix from prefix-overlay, add some
diff --git a/net-irc/ircii/ircii-20111115.ebuild b/net-irc/ircii/ircii-20111115.ebuild
new file mode 100644
index 000000000000..003bd365cf26
--- /dev/null
+++ b/net-irc/ircii/ircii-20111115.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ircii-20111115.ebuild,v 1.1 2011/12/02 00:17:56 binki Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2
+ ftp://ircii.warped.com/pub/ircII/old/${P}.tar.bz2"
+HOMEPAGE="http://eterna.com.au/ircii/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6"
+
+DEPEND="sys-libs/ncurses
+ virtual/libiconv"
+# This and irc-client both install /usr/bin/irc #247987
+RDEPEND="${DEPEND}
+ !!net-irc/irc-client"
+
+src_configure() {
+ use elibc_glibc || append-libs -liconv
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc ChangeLog INSTALL NEWS README \
+ doc/Copyright doc/crypto doc/VERSIONS doc/ctcp
+}