summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ddclient/ChangeLog8
-rw-r--r--net-dns/ddclient/ddclient-3.7.3.ebuild74
-rw-r--r--net-dns/ddclient/files/digest-ddclient-3.7.33
3 files changed, 84 insertions, 1 deletions
diff --git a/net-dns/ddclient/ChangeLog b/net-dns/ddclient/ChangeLog
index 1d173dfcc038..00c0b184542f 100644
--- a/net-dns/ddclient/ChangeLog
+++ b/net-dns/ddclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/ddclient
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.27 2007/08/08 03:17:32 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.28 2007/08/21 13:46:09 uberlord Exp $
+
+*ddclient-3.7.3 (21 Aug 2007)
+
+ 21 Aug 2007; Roy Marples <uberlord@gentoo.org> +ddclient-3.7.3.ebuild:
+ Rework the install section so we don't have to change back to the root/wheel
+ group so we can install on FreeBSD Keyworded ~x86-fbsd and bumped, #170708.
*ddclient-3.7.2-r1 (08 Aug 2007)
diff --git a/net-dns/ddclient/ddclient-3.7.3.ebuild b/net-dns/ddclient/ddclient-3.7.3.ebuild
new file mode 100644
index 000000000000..42040b236827
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.7.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ddclient-3.7.3.ebuild,v 1.1 2007/08/21 13:46:09 uberlord Exp $
+
+inherit eutils
+
+DESCRIPTION="Perl updater client for dynamic DNS services"
+HOMEPAGE="http://ddclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl"
+
+RDEPEND=">=dev-lang/perl-5.1
+ ssl? ( dev-perl/IO-Socket-SSL )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-reasonable-security.patch"
+
+ einfo "Applying version string fix"
+ if ! sed -i "s/3\.7\.1/$PV/" "$PN"; then
+ eerror "Failed to update ddclient's internal version string"
+ eerror 'ddclient 3.7.2 will erroneously report a version of 3.7.1'
+ fi
+
+ # Remove pid line, because it is specified in /etc/conf.d/ddclient
+ einfo "Applying PID setup"
+ if ! sed -i "/^pid=*/d" "sample-etc_${PN}.conf"; then
+ eerror "Failed to remove pid from /etc/$PN/$PN.conf"
+ eerror "Please set the PID in /etc/conf.d/$PN, not /etc/$PN/$PN.conf"
+ fi
+
+ if ! use ssl; then
+ einfo "Disabling ssl per your useflags"
+ sed -i "/^ssl=*/d" "sample-etc_${PN}.conf" ||
+ eerror "Failed to remove ssl from /etc/$PN/$PN.conf"
+ fi
+}
+
+src_install() {
+ dosbin ${PN} || die "dosbin failed"
+ dodoc README* Change* COPYRIGHT sample*
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ keepdir /var/{cache,run}/${PN}
+
+ # Filename of sample conf - use live filename if available
+ local sample=${PN}.conf
+ [[ -e "${ROOT}/etc/${PN}/${sample}" ]] && sample="${sample}.sample"
+ insinto /etc/${PN}
+ insopts -m 0640 -o root -g ${PN}
+ newins sample-etc_${PN}.conf "${sample}" || die "newins conf failed"
+}
+
+pkg_postinst() {
+ use ssl && return
+ ewarn
+ ewarn "$PN will not have support for ssl, which means your dynamic DNS account"
+ ewarn "information -- including your password -- will be sent over the Internet in the"
+ ewarn "clear. To secure your information, add 'ssl' to your USEflags,"
+ ewarn "emerge -N ddclient, and add 'ssl=yes' to /etc/$PN/$PN.conf"
+ ewarn
+}
diff --git a/net-dns/ddclient/files/digest-ddclient-3.7.3 b/net-dns/ddclient/files/digest-ddclient-3.7.3
new file mode 100644
index 000000000000..6cd8d0a6580c
--- /dev/null
+++ b/net-dns/ddclient/files/digest-ddclient-3.7.3
@@ -0,0 +1,3 @@
+MD5 5459ae165e74437587b6e84225a7fbf0 ddclient-3.7.3.tar.gz 42034
+RMD160 df40a809132102b9326fa7e9d735723e1de8ed37 ddclient-3.7.3.tar.gz 42034
+SHA256 f1f57fdca170d9349cb99a3b8b33672d983e0e41c43c2bbb940927380ee12962 ddclient-3.7.3.tar.gz 42034