summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/rtpbreak/ChangeLog8
-rw-r--r--net-analyzer/rtpbreak/files/rtpbreak-1.3a-limits.patch10
-rw-r--r--net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild37
3 files changed, 54 insertions, 1 deletions
diff --git a/net-analyzer/rtpbreak/ChangeLog b/net-analyzer/rtpbreak/ChangeLog
index f98f0958831e..1aaab51b4cbe 100644
--- a/net-analyzer/rtpbreak/ChangeLog
+++ b/net-analyzer/rtpbreak/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/rtpbreak
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtpbreak/ChangeLog,v 1.3 2009/01/14 04:20:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtpbreak/ChangeLog,v 1.4 2009/02/05 13:56:41 drizzt Exp $
+
+*rtpbreak-1.3a (05 Feb 2009)
+
+ 05 Feb 2009; Timothy Redaelli <drizzt@gentoo.org>
+ +files/rtpbreak-1.3a-limits.patch, +rtpbreak-1.3a.ebuild:
+ Version bump, new homepage and add ~amd64 keyword
14 Jan 2009; Mike Frysinger <vapier@gentoo.org>
+files/rtpbreak-1.2-build.patch, rtpbreak-1.2.ebuild:
diff --git a/net-analyzer/rtpbreak/files/rtpbreak-1.3a-limits.patch b/net-analyzer/rtpbreak/files/rtpbreak-1.3a-limits.patch
new file mode 100644
index 000000000000..78cb5f9a5a78
--- /dev/null
+++ b/net-analyzer/rtpbreak/files/rtpbreak-1.3a-limits.patch
@@ -0,0 +1,10 @@
+--- rtpbreak-1.3a/src/common.h.orig 2009-02-05 14:49:50.000000000 +0100
++++ rtpbreak-1.3a/src/common.h 2009-02-05 14:49:57.000000000 +0100
+@@ -30,6 +30,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <errno.h>
++#include <limits.h>
+
+
+ /* const */
diff --git a/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild b/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild
new file mode 100644
index 000000000000..c89bca5507fb
--- /dev/null
+++ b/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild,v 1.1 2009/02/05 13:56:41 drizzt Exp $
+
+EAPI=1
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Detects, reconstructs and analyzes any RTP session through heuristics over the UDP network traffic"
+HOMEPAGE="http://xenion.reactive-search.com/?page_id=7"
+SRC_URI="http://xenion.antifork.org/rtpbreak/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libnet:1.1
+ >=net-libs/libpcap-0.7"
+
+RDEPEND=$DEPEND
+
+src_unpack() {
+ unpack ${A}
+ # Use limits.h PATH_MAX
+ epatch "${FILESDIR}"/${P}-limits.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin src/rtpbreak || die "cannot install rtpbreak"
+ dodoc CHANGELOG THANKS
+ dohtml docs/*
+}