summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios-plugins')
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild7
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild6
2 files changed, 4 insertions, 9 deletions
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
index 759e2b30b9b9..3008ba676c0b 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild,v 1.6 2004/08/04 22:04:13 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild,v 1.7 2004/08/04 22:18:17 squinky86 Exp $
inherit eutils
@@ -32,6 +32,7 @@ RDEPEND=">=dev-lang/perl-5.6.1-r7
pkg_preinst() {
enewgroup nagios
enewuser nagios -1 /bin/bash /dev/null nagios
+ chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}/usr/nagios/libexec"
}
src_compile() {
@@ -64,10 +65,6 @@ src_install() {
mv ${S}/contrib ${D}/usr/nagios/libexec/contrib
}
-pkg_preinst() {
- chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}/usr/nagios/libexec"
-}
-
pkg_postinst() {
einfo "This ebuild has a number of USE flags which determines what nagios is able to monitor."
einfo "Depending on what you want to monitor with nagios, some or all of these USE"
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild
index d59b004dcf95..18c5b5e8a24e 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild,v 1.6 2004/08/04 22:04:13 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild,v 1.7 2004/08/04 22:18:17 squinky86 Exp $
inherit eutils
@@ -29,6 +29,7 @@ DEPEND=">=net-dns/bind-tools-9.2.2_rc1
pkg_preinst() {
enewgroup nagios
enewuser nagios -1 /bin/bash /dev/null nagios
+ chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}/usr/nagios/libexec"
}
src_compile() {
@@ -51,6 +52,3 @@ src_install() {
dodoc AUTHORS CODING COPYING ChangeLog FAQ INSTALL LEGALNEWS README REQUIREMENTS ROADMAP Requirements
make DESTDIR=${D} install || die
}
-pkg_preinst() {
- chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}/usr/nagios/libexec"
-}