summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cogl/ChangeLog11
-rw-r--r--media-libs/cogl/cogl-1.8.2.ebuild67
-rw-r--r--media-libs/cogl/metadata.xml12
3 files changed, 90 insertions, 0 deletions
diff --git a/media-libs/cogl/ChangeLog b/media-libs/cogl/ChangeLog
new file mode 100644
index 000000000000..c3cc83d063e7
--- /dev/null
+++ b/media-libs/cogl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-libs/cogl
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.1 2011/10/28 21:56:11 tetromino Exp $
+
+*cogl-1.8.2 (28 Oct 2011)
+
+ 28 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org> +cogl-1.8.2.ebuild,
+ +metadata.xml:
+ New package, moved from the gnome overlay. Formerly part of
+ media-libs/clutter. Required for clutter-1.8.
+
diff --git a/media-libs/cogl/cogl-1.8.2.ebuild b/media-libs/cogl/cogl-1.8.2.ebuild
new file mode 100644
index 000000000000..12880b5bd7de
--- /dev/null
+++ b/media-libs/cogl/cogl-1.8.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.8.2.ebuild,v 1.1 2011/10/28 21:56:11 tetromino Exp $
+
+EAPI="4"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+inherit clutter gnome2 virtualx
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="http://www.clutter-project.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0"
+IUSE="doc examples +introspection +pango"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# XXX: need uprof for optional profiling support
+COMMON_DEPEND=">=dev-libs/glib-2.26.0:2
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libdrm
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ virtual/opengl
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.13 )"
+
+# XXX: at least when using nvidia-drivers, tests fail under Xemake/Xvfb, no
+# matter whether "eselect opengl" is set to nvidia or xorg-x11.
+RESTRICT="test"
+
+pkg_setup() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/{*.c,*.jpg}"
+ # XXX: think about gles, quartz, wayland
+ G2CONF="${G2CONF}
+ --disable-profile
+ --disable-maintainer-flags
+ --enable-cairo
+ --enable-gdk-pixbuf
+ --enable-gl
+ --enable-glx
+ $(use_enable introspection)
+ $(use_enable pango cogl-pango)"
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ clutter_src_install
+}
diff --git a/media-libs/cogl/metadata.xml b/media-libs/cogl/metadata.xml
new file mode 100644
index 000000000000..2568db9ec971
--- /dev/null
+++ b/media-libs/cogl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ <flag name="pango">Build cogl-pango library for <pkg>x11-libs/pango</pkg>
+ integration</flag>
+</use>
+</pkgmetadata>
+