summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/yiff')
-rw-r--r--media-libs/yiff/files/yiff-2.14.2-gcc33.patch31
-rw-r--r--media-libs/yiff/yiff-2.14.2.ebuild18
2 files changed, 42 insertions, 7 deletions
diff --git a/media-libs/yiff/files/yiff-2.14.2-gcc33.patch b/media-libs/yiff/files/yiff-2.14.2-gcc33.patch
new file mode 100644
index 000000000000..a8cfdd651717
--- /dev/null
+++ b/media-libs/yiff/files/yiff-2.14.2-gcc33.patch
@@ -0,0 +1,31 @@
+Work around a gcc-3.3.x bug where redefining prototypes with different
+__THROW / attribute(nonnull) markings throws an error:
+
+string.cpp:31: error: declaration of `char* strcasestr(const char*, const char*)' throws different exceptions
+../include/string.h:46: error: than previous declaration `char* strcasestr(const char*, const char*) throw ()'
+
+basically we just use the glibc strcasestr() instead of the internal one.
+
+http://bugs.gentoo.org/show_bug.cgi?id=85780
+
+--- string.cpp
++++ string.cpp
+@@ -37,3 +37,5 @@
+ const char *strseekblank(const char *s);
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle);
++#endif
+ int strpfx(const char *str, const char *pfx);
+@@ -220,3 +220,4 @@
+ */
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle)
+ {
+@@ -275,6 +275,7 @@
+
+ return(NULL);
+ }
++#endif
+
+ /*
+ * Returns 1 if pfx is a prefix of str.
diff --git a/media-libs/yiff/yiff-2.14.2.ebuild b/media-libs/yiff/yiff-2.14.2.ebuild
index 2263693e8f7e..767475d061f4 100644
--- a/media-libs/yiff/yiff-2.14.2.ebuild
+++ b/media-libs/yiff/yiff-2.14.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/yiff-2.14.2.ebuild,v 1.11 2004/10/08 09:57:14 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/yiff-2.14.2.ebuild,v 1.12 2005/04/19 00:18:54 vapier Exp $
inherit flag-o-matic eutils kde
@@ -10,17 +10,21 @@ SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc amd64"
+KEYWORDS="amd64 ppc sparc x86"
IUSE="gtk alsa"
DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
- !sparc? ( alsa? ( media-libs/alsa-lib ) )"
+ alsa? ( media-libs/alsa-lib )"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-gcc3.patch
- epatch ${FILESDIR}/${P}-PIC.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc3.patch
+ epatch "${FILESDIR}"/${P}-PIC.patch
+ for d in libY2 yiff{,config,utils} ; do
+ cd "${S}"/${d}
+ epatch "${FILESDIR}"/${P}-gcc33.patch
+ done
}
src_compile() {