summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-memcached')
-rw-r--r--dev-python/python-memcached/ChangeLog6
-rw-r--r--dev-python/python-memcached/python-memcached-1.44.ebuild17
2 files changed, 12 insertions, 11 deletions
diff --git a/dev-python/python-memcached/ChangeLog b/dev-python/python-memcached/ChangeLog
index 0ff9532dbac0..986ec75ddd21 100644
--- a/dev-python/python-memcached/ChangeLog
+++ b/dev-python/python-memcached/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-memcached
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/ChangeLog,v 1.11 2010/03/26 02:48:00 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/ChangeLog,v 1.12 2010/07/06 19:33:00 arfrever Exp $
+
+ 06 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-memcached-1.44.ebuild:
+ Use PYTHON_DEPEND instead of NEED_PYTHON.
26 Mar 2010; Sebastian Pipping <sping@gentoo.org>
python-memcached-1.44.ebuild:
diff --git a/dev-python/python-memcached/python-memcached-1.44.ebuild b/dev-python/python-memcached/python-memcached-1.44.ebuild
index 8b95dc361b85..5fffb7397060 100644
--- a/dev-python/python-memcached/python-memcached-1.44.ebuild
+++ b/dev-python/python-memcached/python-memcached-1.44.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/python-memcached-1.44.ebuild,v 1.6 2010/03/26 02:48:00 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/python-memcached-1.44.ebuild,v 1.7 2010/07/06 19:33:00 arfrever Exp $
-NEED_PYTHON="2.4"
+EAPI="3"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
-DESCRIPTION="A Python based API (implemented in 100% python) for
-communicating with the memcached distributed memory object cache daemon."
-HOMEPAGE="http://www.tummy.com/Community/software/python-memcached/"
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="http://www.tummy.com/Community/software/python-memcached/ http://pypi.python.org/pypi/python-memcached"
SRC_URI="ftp://ftp.tummy.com/pub/python-memcached/old-releases/${P}.tar.gz"
LICENSE="OSL-2.0"
@@ -20,8 +21,4 @@ IUSE=""
DEPEND="dev-python/setuptools"
RDEPEND=""
-RESTRICT_PYTHON_ABIS="3*"
-
-pkg_postinst() {
- python_mod_optimize memcache.py
-}
+PYTHON_MODNAME="memcache.py"