summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/paisley/paisley-0.1.ebuild')
-rw-r--r--dev-python/paisley/paisley-0.1.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/paisley/paisley-0.1.ebuild b/dev-python/paisley/paisley-0.1.ebuild
index fc9352828261..f7b9881a1b86 100644
--- a/dev-python/paisley/paisley-0.1.ebuild
+++ b/dev-python/paisley/paisley-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paisley/paisley-0.1.ebuild,v 1.3 2009/11/30 18:20:43 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paisley/paisley-0.1.ebuild,v 1.4 2009/12/08 15:58:13 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -14,12 +14,20 @@ SRC_URI="http://pypi.python.org/packages/source/p/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="test"
-DEPEND=""
-RDEPEND="dev-python/twisted"
+RDEPEND="dev-python/simplejson
+ dev-python/twisted
+ dev-python/twisted-web"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_MODNAME="paisley.py"
+
src_test() {
- python test_paisley.py
+ testing() {
+ nosetests-${PYTHON_ABI} test_paisley.py
+ }
+ python_execute_function testing
}