summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/POE/POE-0.23-r1.ebuild')
-rw-r--r--dev-perl/POE/POE-0.23-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/POE/POE-0.23-r1.ebuild b/dev-perl/POE/POE-0.23-r1.ebuild
new file mode 100644
index 000000000000..4832029e34c7
--- /dev/null
+++ b/dev-perl/POE/POE-0.23-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/POE/POE-0.23-r1.ebuild,v 1.1 2002/10/30 07:20:40 seemant Exp $
+
+IUSE="gtk tcltk libwww curses"
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A framework for creating multitasking programs in Perl"
+HOMEPAGE="http://poe.perl.org"
+SRC_URI="mirror://sourceforge/poe/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+DEPEND="${DEPEND}
+ dev-perl/Event
+ dev-perl/Time-HiRes
+ dev-perl/Compress-Zlib
+ dev-perl/Storable
+ dev-perl/IO-Tty
+ dev-perl/Filter
+ dev-perl/FreezeThaw
+ tcltk? ( dev-perl/perl-tk )
+ gtk? ( dev-perl/gtk-perl )
+ libwww? ( dev-perl/libwww-perl )
+ curses? ( dev-perl/Curses )"
+
+mymake="/usr"
+
+src_compile() {
+
+ echo "n" | perl-module_src_compile
+ }
+