summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Mail-DKIM')
-rw-r--r--dev-perl/Mail-DKIM/ChangeLog7
-rw-r--r--dev-perl/Mail-DKIM/Mail-DKIM-0.37.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-perl/Mail-DKIM/ChangeLog b/dev-perl/Mail-DKIM/ChangeLog
index 8031ac634af2..a4d6b4863471 100644
--- a/dev-perl/Mail-DKIM/ChangeLog
+++ b/dev-perl/Mail-DKIM/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Mail-DKIM
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-DKIM/ChangeLog,v 1.29 2009/09/07 08:52:20 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-DKIM/ChangeLog,v 1.30 2009/09/09 11:07:03 tove Exp $
+
+*Mail-DKIM-0.37 (09 Sep 2009)
+
+ 09 Sep 2009; Torsten Veller <tove@gentoo.org> +Mail-DKIM-0.37.ebuild:
+ Version bump
07 Sep 2009; Torsten Veller <tove@gentoo.org> -Mail-DKIM-0.33.ebuild,
-Mail-DKIM-0.35.ebuild:
diff --git a/dev-perl/Mail-DKIM/Mail-DKIM-0.37.ebuild b/dev-perl/Mail-DKIM/Mail-DKIM-0.37.ebuild
new file mode 100644
index 000000000000..37d2553cd213
--- /dev/null
+++ b/dev-perl/Mail-DKIM/Mail-DKIM-0.37.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-DKIM/Mail-DKIM-0.37.ebuild,v 1.1 2009/09/09 11:07:03 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=JASLONG
+inherit perl-module
+
+DESCRIPTION="Mail::DKIM - Signs/verifies Internet mail using DKIM message signatures"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-perl/Crypt-OpenSSL-RSA-0.24
+ virtual/perl-Digest-SHA
+ virtual/perl-MIME-Base64
+ dev-perl/Net-DNS
+ dev-perl/MailTools"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
+
+src_test(){
+ # disable online tests
+ for test in policy public_key verifier ; do
+ mv "${S}"/t/${test}.t{,.disable}
+ done
+ perl-module_src_test
+}